From mboxrd@z Thu Jan 1 00:00:00 1970 From: Ilija Hadzic Subject: Re: [PATCH] kernel/drm: vblank wait on crtc > 1 Date: Tue, 22 Mar 2011 06:16:30 -0500 (CDT) Message-ID: References: <1300792324.3476.23.camel@thor.local> Mime-Version: 1.0 Content-Type: MULTIPART/MIXED; BOUNDARY="-559023410-758783491-1300792590=:6801" Return-path: Received: from ihemail2.lucent.com (ihemail2.lucent.com [135.245.0.35]) by gabe.freedesktop.org (Postfix) with ESMTP id 64D729ECC0 for ; Tue, 22 Mar 2011 04:16:40 -0700 (PDT) In-Reply-To: <1300792324.3476.23.camel@thor.local> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org Errors-To: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org To: Michel =?ISO-8859-1?Q?D=E4nzer?= Cc: dri-devel@lists.freedesktop.org List-Id: dri-devel@lists.freedesktop.org This message is in MIME format. The first part should be readable text, while the remaining parts are likely unreadable without MIME-aware tools. ---559023410-758783491-1300792590=:6801 Content-Type: TEXT/PLAIN; charset=UTF-8; format=flowed Content-Transfer-Encoding: QUOTED-PRINTABLE Unless I oversaw something nothing was silently ignored. I believe I=20 responded to each of your comments (and comments by others), those I=20 agreed with I implemented, those I didn't agree with I didn't implement. -- Ilija On Tue, 22 Mar 2011, Michel [ISO-8859-1] D=E4nzer wrote: > On Fre, 2011-03-18 at 16:58 -0500, Ilija Hadzic wrote: >> >> This patch extends the interface to drm_wait_vblank ioctl so that crtc>1 >> can be represented. It also adds a new capability to drm_getcap ioctl so >> that the user space can check whether the new interface to drm_wait_vbla= nk >> is supported (and fall back to the legacy interface if not) > > [...] > > > You seem to have silently ignored my previous concerns and suggestions > about the handling of the high CRTC mask/shift. > > >> @@ -753,6 +755,7 @@ struct drm_event_vblank { >> }; >> >> #define DRM_CAP_DUMB_BUFFER 0x1 >> +#define DRM_CAP_HIGH_CRTC 0x2 > > Seems like a rather generic name, something like > DRM_CAP_VBLANK_HIGH_CRTC might be better. > > > --=20 > Earthling Michel D=C3=A4nzer | http://www.vmware= =2Ecom > Libre software enthusiast | Debian, X and DRI developer > > > > > > > ---559023410-758783491-1300792590=:6801 Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline _______________________________________________ dri-devel mailing list dri-devel@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/dri-devel ---559023410-758783491-1300792590=:6801--