From: Alyssa Rosenzweig <alyssa@collabora.com>
To: alyssa.rosenzweig@collabora.com
Cc: tomeu.vizoso@collabora.com, airlied@linux.ie,
dri-devel@lists.freedesktop.org, steven.price@arm.com
Subject: Re: [PATCH 0/4] drm/panfrost: Plumb cycle counters to userspace
Date: Thu, 27 May 2021 17:14:31 -0400 [thread overview]
Message-ID: <YLALtwJOJ2Epiw2c@maud> (raw)
In-Reply-To: <20210527203804.12914-1-alyssa.rosenzweig@collabora.com>
> The main outstanding questing is the proper name. Performance monitoring
> ("PERMON") is the name used by kbase, but it's jargon-y and risks
> confusion with performance counters, an orthogonal mechanism. Cycle
> count is more descriptive and matches the actual hardware name, but
> obscures that the same mechanism is required for GPU timestamps. This
> bit of bikeshedding aside, I'm pleased with the patches.
PANFROST_JD_REQ_CLOCK might be the clearest.
next prev parent reply other threads:[~2021-05-27 21:14 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-05-27 20:38 [PATCH 0/4] drm/panfrost: Plumb cycle counters to userspace alyssa.rosenzweig
2021-05-27 20:38 ` [PATCH 1/4] drm/panfrost: Add cycle counter job requirement alyssa.rosenzweig
2021-06-02 11:50 ` Steven Price
2021-05-27 20:38 ` [PATCH 2/4] drm/panfrost: Add CYCLE_COUNT_START/STOP commands alyssa.rosenzweig
2021-06-02 11:50 ` Steven Price
2021-05-27 20:38 ` [PATCH 3/4] drm/panfrost: Add permon acquire/release helpers alyssa.rosenzweig
2021-06-02 11:50 ` Steven Price
2021-05-27 20:38 ` [PATCH 4/4] drm/panfrost: Handle PANFROST_JD_REQ_PERMON alyssa.rosenzweig
2021-06-02 11:50 ` Steven Price
2021-05-27 21:14 ` Alyssa Rosenzweig [this message]
2021-05-28 6:07 ` [PATCH 0/4] drm/panfrost: Plumb cycle counters to userspace Tomeu Vizoso
2021-05-28 13:31 ` Alyssa Rosenzweig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YLALtwJOJ2Epiw2c@maud \
--to=alyssa@collabora.com \
--cc=airlied@linux.ie \
--cc=alyssa.rosenzweig@collabora.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=steven.price@arm.com \
--cc=tomeu.vizoso@collabora.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox