From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from gabe.freedesktop.org (gabe.freedesktop.org [131.252.210.177]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.lore.kernel.org (Postfix) with ESMTPS id 9116AC433F5 for ; Tue, 8 Feb 2022 00:30:49 +0000 (UTC) Received: from gabe.freedesktop.org (localhost [127.0.0.1]) by gabe.freedesktop.org (Postfix) with ESMTP id A6C8610E128; Tue, 8 Feb 2022 00:30:48 +0000 (UTC) Received: from perceval.ideasonboard.com (perceval.ideasonboard.com [213.167.242.64]) by gabe.freedesktop.org (Postfix) with ESMTPS id 894E510E128 for ; Tue, 8 Feb 2022 00:30:47 +0000 (UTC) Received: from pendragon.ideasonboard.com (62-78-145-57.bb.dnainternet.fi [62.78.145.57]) by perceval.ideasonboard.com (Postfix) with ESMTPSA id 59492340; Tue, 8 Feb 2022 01:30:45 +0100 (CET) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ideasonboard.com; s=mail; t=1644280245; bh=myyYYwF0zw0KqcsUrHoCyxQvYmLiqqpmlW/RBPnVask=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=pw/5iLsIlW/vT3n6wFmZjGchQqYtpgEt25SHIvD54VsSOXeRi02D6UsGvE4vQ/PRC zsU7e8i77HLbdtsPNMHPOxwmH83bEL3IRxYpR3V0Ib/X6PBE2o+FfGq2Ag18sD33N5 Anwm1Jhj/7hBi22Vi5LO4W1bcPNXBwjhtE2kOgnY= Date: Tue, 8 Feb 2022 02:30:42 +0200 From: Laurent Pinchart To: Sam Ravnborg Subject: Re: [PATCH v1 1/9] drm/bridge: add DRM_BRIDGE_STATE_OPS macro Message-ID: References: <20220206154405.1243333-1-sam@ravnborg.org> <20220206154405.1243333-2-sam@ravnborg.org> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20220206154405.1243333-2-sam@ravnborg.org> X-BeenThere: dri-devel@lists.freedesktop.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Direct Rendering Infrastructure - Development List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Rob Clark , Philip Chen , Jitao Shi , Thomas Zimmermann , Jonas Karlman , Robert Foss , Neil Armstrong , Douglas Anderson , Jernej Skrabec , Andrzej Hajda , dri-devel@lists.freedesktop.org, Enric Balletbo i Serra Errors-To: dri-devel-bounces@lists.freedesktop.org Sender: "dri-devel" Hi Sam, Thank you for the patch. On Sun, Feb 06, 2022 at 04:43:57PM +0100, Sam Ravnborg wrote: > The DRM_BRIDGE_STATE_OPS can be used as shortcut for bridge drivers that > do not subclass drm_bridge_state to assign the default operations for > reset, duplicate and destroy of the state. > > Signed-off-by: Sam Ravnborg > Cc: Douglas Anderson > Cc: Andrzej Hajda > Cc: Neil Armstrong > Cc: Robert Foss > Cc: Laurent Pinchart > Cc: Jonas Karlman > Cc: Jernej Skrabec > Cc: Maxime Ripard > Cc: Thomas Zimmermann > --- > include/drm/drm_bridge.h | 12 ++++++++++++ > 1 file changed, 12 insertions(+) > > diff --git a/include/drm/drm_bridge.h b/include/drm/drm_bridge.h > index 061d87313fac..fc00304be643 100644 > --- a/include/drm/drm_bridge.h > +++ b/include/drm/drm_bridge.h > @@ -935,4 +935,16 @@ static inline struct drm_bridge *devm_drm_of_get_bridge(struct device *dev, > } > #endif > > +/** > + * DRM_BRIDGE_STATE_OPS - Default drm_bridge state funcs I'd name the macro DRM_BRIDGE_STATE_DEFAULT_OPS. > + * > + * Bridge driver that do not subclass &drm_bridge_state can use the helpers > + * for reset, duplicate, and destroy. This macro provides a shortcut for > + * setting the helpers in the &drm_bridge_funcs structure. > + */ > +#define DRM_BRIDGE_STATE_OPS \ > + .atomic_reset = drm_atomic_helper_bridge_reset, \ > + .atomic_duplicate_state = drm_atomic_helper_bridge_duplicate_state, \ > + .atomic_destroy_state = drm_atomic_helper_bridge_destroy_state I'm not a big fan of such macros for a small number of operations, as I find that it obfuscates the code a bit, but that could change once I get used to the new macro :-) Reviewed-by: Laurent Pinchart > + > #endif -- Regards, Laurent Pinchart