dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Helge Deller <deller@gmx.de>
To: "Uwe Kleine-König (The Capable Hub)" <u.kleine-koenig@baylibre.com>
Cc: linux-ide@vger.kernel.org, linux-m68k@lists.linux-m68k.org,
	linux-kernel@vger.kernel.org, linux-scsi@vger.kernel.org,
	netdev@vger.kernel.org, linux-i2c@vger.kernel.org,
	linux-fbdev@vger.kernel.org, dri-devel@lists.freedesktop.org,
	"Christian A. Ehrhardt" <christian.ehrhardt@codasip.com>,
	"Christian A. Ehrhardt" <lk@c--e.de>
Subject: Re: [PATCH v1 0/8] zorro: Improve handling of pointers in zorro_device_id::driver_data
Date: Fri, 5 Jun 2026 00:44:04 +0200	[thread overview]
Message-ID: <a3f9e96e-3bbb-4cfc-845c-58649405a1cf@gmx.de> (raw)
In-Reply-To: <cover.1779803053.git.u.kleine-koenig@baylibre.com>

Hi Uwe,

On 5/26/26 16:17, Uwe Kleine-König (The Capable Hub) wrote:
> Hello,
> 
> this series is about improving the handling of pointers in struct
> zorro_device_id's driver_data.
> 
> While it's ok on all current Linux platforms to store a pointer in an
> unsigned long variable, it involves casting that loses type information.
> This can be nicely seen in patch #7 where after profiting from patch #6
> the compiler notices a missing const.
> 
> Preparing for that change, all zorro_device_ids are converted to use
> named initializers, which is also a nice cleanup that could stand for
> itself, as it improves readability for humans. (That is necessary
> because an anonymous union can be initialized by name, but not using a
> list initializer.)
> 
> My motivation for this series is the CHERI hardware extension. With that
> pointers are bigger than longs and thus you cannot store pointers in
> zorro_device_id::driver_data. So this series is also about getting
> support for CHERI into the mainline, but I hope the clean up effects
> mentioned above are justification enough to accept this series.
> 
> The dependencies in this series are as follows:
> 
>   - Patch #5 depends on #1, #2
>   - Patches #7 and #8 depend on patch #6.
> 
> So if the ata maintainers agreed to merge their patch #1 via scsi, and
> Geert agrees to patch #5 and that it's also merged via scsi, patches #1,
> #2, #6 and #7 can go in without further coordination.
> 
> Patches #3, #4 and #5 are only about using the same initialization style
> for all zorro_device_id and can go in without coordination.
> 
> Best regards
> Uwe
> 
> Uwe Kleine-König (The Capable Hub) (8):
>    ata: pata_budda: Use named initializer for zorro_device_id
>    scsi: Use named initializer for zorro_device_id
>    net: Use named initializer for zorro_device_id arrays
>    i2c: icy: Use named initializer for zorro_device_id arrays
>    video: fm2fb: Use named initializer for zorro_device_id array
>    zorro: Simplify storing pointers in device id struct
>    scsi: zorro7xx: Make use of struct zorro_device_id::driver_data_ptr
>    video: cirrusfb: Make use of struct zorro_device_id::driver_data_ptr
> 
>   drivers/ata/pata_buddha.c             |  8 ++++----
>   drivers/i2c/busses/i2c-icy.c          |  4 ++--
>   drivers/net/ethernet/8390/hydra.c     |  4 ++--
>   drivers/net/ethernet/8390/xsurf100.c  |  4 ++--
>   drivers/net/ethernet/8390/zorro8390.c |  6 +++---
>   drivers/net/ethernet/amd/a2065.c      |  8 ++++----
>   drivers/net/ethernet/amd/ariadne.c    |  4 ++--
>   drivers/scsi/a2091.c                  |  6 +++---
>   drivers/scsi/gvp11.c                  | 17 ++++++++--------
>   drivers/scsi/zorro7xx.c               | 16 +++++++--------
>   drivers/scsi/zorro_esp.c              |  2 +-
>   drivers/video/fbdev/cirrusfb.c        | 28 +++++++++++++--------------
>   drivers/video/fbdev/fm2fb.c           |  6 +++---
>   include/linux/mod_devicetable.h       |  6 +++++-
>   14 files changed, 62 insertions(+), 57 deletions(-)

you may add to the series:
Acked-by: Helge Deller <deller@gmx.de>

Since it touches various subtrees, I assume you will merge it though your tree?

Helge

  parent reply	other threads:[~2026-06-04 22:44 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-26 14:17 [PATCH v1 0/8] zorro: Improve handling of pointers in zorro_device_id::driver_data Uwe Kleine-König (The Capable Hub)
2026-05-26 14:17 ` [PATCH v1 5/8] video: fm2fb: Use named initializer for zorro_device_id array Uwe Kleine-König (The Capable Hub)
2026-05-27 13:17   ` Geert Uytterhoeven
2026-05-26 14:17 ` [PATCH v1 6/8] zorro: Simplify storing pointers in device id struct Uwe Kleine-König (The Capable Hub)
2026-05-27 13:18   ` Geert Uytterhoeven
2026-05-28  7:50   ` Max Staudt
2026-05-26 14:17 ` [PATCH v1 8/8] video: cirrusfb: Make use of struct zorro_device_id::driver_data_ptr Uwe Kleine-König (The Capable Hub)
2026-05-27 13:19   ` Geert Uytterhoeven
2026-05-26 15:01 ` [PATCH v1 0/8] zorro: Improve handling of pointers in zorro_device_id::driver_data Geert Uytterhoeven
2026-05-26 16:38   ` Uwe Kleine-König (The Capable Hub)
2026-05-29  1:20 ` patchwork-bot+netdevbpf
2026-06-04 22:44 ` Helge Deller [this message]
2026-06-05 11:56   ` Uwe Kleine-König (The Capable Hub)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a3f9e96e-3bbb-4cfc-845c-58649405a1cf@gmx.de \
    --to=deller@gmx.de \
    --cc=christian.ehrhardt@codasip.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-i2c@vger.kernel.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-m68k@lists.linux-m68k.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=lk@c--e.de \
    --cc=netdev@vger.kernel.org \
    --cc=u.kleine-koenig@baylibre.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox