From: Sui Jingfeng <sui.jingfeng@linux.dev>
To: Thomas Zimmermann <tzimmermann@suse.de>,
airlied@redhat.com, jfalempe@redhat.com,
maarten.lankhorst@linux.intel.com, mripard@kernel.org,
jani.nikula@linux.intel.com, airlied@gmail.com, daniel@ffwll.ch
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [v5,06/13] drm/ast: Rename struct ast_i2c_chan to struct ast_ddc
Date: Thu, 21 Mar 2024 16:48:06 +0800 [thread overview]
Message-ID: <b52c0030-77ef-4bc2-8ad4-a6acf54fbd5d@linux.dev> (raw)
In-Reply-To: <08e70629-72aa-4102-955c-dc531ca5589d@suse.de>
Hi,
On 2024/3/21 16:13, Thomas Zimmermann wrote:
> Hi
>
> Am 20.03.24 um 18:32 schrieb Sui Jingfeng:
>> Hi,
>>
>>
>> On 2024/3/20 17:34, Thomas Zimmermann wrote:
>>> The struct struct ast_i2c_chan represents the Display Data Channel
>>> (DDC); I2C is the underlying bus. Rename the structure, the variables
>>> and the helper ast_i2c_create() to ddc-like terms. No functional
>>> changes.
>>>
>>> Signed-off-by: Thomas Zimmermann <tzimmermann@suse.de>
>>
>>
>> Personally, I think _i2c_ is better name than _ddc_. Because It seems
>> that
>> the Display Data Channel is comes from VESA standard, while aspeed
>> I2C can
>> be used to configure the external display bridges(encoder). So _i2c_
>> is a
>> *abstract* name, and can be utilized to do something else beyond the DDC
>> itself.
>
> This specific instance of i2c is for DDC; even the AST manual refers
> to it as DDC. I don't think there's anything else we could do with
> those registers. If we have other uses for i2c, we can easily add them
> in separate code.
>
>>
>>
>> Reviewed-by: Sui Jingfeng <sui.jingfeng@linux.dev>
>
> Thanks for reviewing the series. I think the new helper in patch 12
> could be useful for loongson [1][2] as well.
>
Yes, after this series landed. I'm going to post a few patch to remove some boilerplate.
I want to follow as well, but need a period of time. I have tested the whole series with
ast 2600 dGPU, the /sys/class/.../status will reflect the physical hut-plug status.
> Best regards
> Thomas
>
> [1]
> https://elixir.bootlin.com/linux/v6.8/source/drivers/gpu/drm/loongson/lsdc_output_7a1000.c#L80
> [2]
> https://elixir.bootlin.com/linux/v6.8/source/drivers/gpu/drm/loongson/lsdc_output_7a2000.c#L177
>
--
Best regards,
Sui
next prev parent reply other threads:[~2024-03-21 8:48 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-20 9:34 [PATCH v5 00/13] drm/ast: Detect connector status for VGA and SIL164 Thomas Zimmermann
2024-03-20 9:34 ` [PATCH v5 01/13] drm/ast: Include <linux/of.h> where necessary Thomas Zimmermann
2024-03-20 17:16 ` [v5,01/13] " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 02/13] drm/ast: Fail probing if DDC channel could not be initialized Thomas Zimmermann
2024-03-20 9:34 ` [PATCH v5 03/13] drm/ast: Remove struct ast_{vga,sil165}_connector Thomas Zimmermann
2024-03-20 9:34 ` [PATCH v5 04/13] drm/ast: Allocate instance of struct ast_i2c_chan with managed helpers Thomas Zimmermann
2024-03-20 17:19 ` [v5, " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 05/13] drm/ast: Move DDC code to ast_ddc.{c,h} Thomas Zimmermann
2024-03-20 17:21 ` [v5,05/13] " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 06/13] drm/ast: Rename struct ast_i2c_chan to struct ast_ddc Thomas Zimmermann
2024-03-20 17:32 ` [v5,06/13] " Sui Jingfeng
2024-03-21 8:13 ` Thomas Zimmermann
2024-03-21 8:48 ` Sui Jingfeng [this message]
2024-03-20 9:34 ` [PATCH v5 07/13] drm/ast: Pass AST device to ast_ddc_create() Thomas Zimmermann
2024-03-20 17:34 ` [v5,07/13] " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 08/13] drm/ast: Store AST device in struct ast_ddc Thomas Zimmermann
2024-03-20 17:35 ` [v5,08/13] " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 09/13] drm/ast: Rename struct i2c_algo_bit_data callbacks and their parameters Thomas Zimmermann
2024-03-20 17:36 ` [v5, " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 10/13] drm/ast: Acquire I/O-register lock in DDC code Thomas Zimmermann
2024-03-20 17:42 ` [v5,10/13] " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 11/13] drm/ast: Use drm_connector_helper_get_modes() Thomas Zimmermann
2024-03-20 17:44 ` [v5,11/13] " Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 12/13] drm/ast: Implement polling for VGA and SIL164 connectors Thomas Zimmermann
2024-03-21 8:56 ` [v5,12/13] " Sui Jingfeng
2024-03-21 14:09 ` [PATCH v5 12/13] " Maxime Ripard
2024-03-22 6:40 ` Thomas Zimmermann
2024-03-22 14:27 ` Maxime Ripard
2024-03-22 8:22 ` Sui Jingfeng
2024-03-20 9:34 ` [PATCH v5 13/13] drm/ast: Automatically clean up poll helper Thomas Zimmermann
2024-03-21 8:22 ` kernel test robot
2024-03-21 9:00 ` [v5,13/13] " Sui Jingfeng
2024-03-21 9:57 ` Thomas Zimmermann
2024-03-21 20:57 ` Sui Jingfeng
2024-03-21 13:37 ` [PATCH v5 00/13] drm/ast: Detect connector status for VGA and SIL164 Jocelyn Falempe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b52c0030-77ef-4bc2-8ad4-a6acf54fbd5d@linux.dev \
--to=sui.jingfeng@linux.dev \
--cc=airlied@gmail.com \
--cc=airlied@redhat.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=jani.nikula@linux.intel.com \
--cc=jfalempe@redhat.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox