From: Lukas Wunner <lukas@wunner.de>
To: Daniel Vetter <daniel.vetter@ffwll.ch>,
DRI Development <dri-devel@lists.freedesktop.org>
Subject: [PATCH RFC 0/5] Re: drm/doc: Rename docbook to gpu.tmpl
Date: Mon, 12 Oct 2015 15:14:57 +0200 [thread overview]
Message-ID: <cover.1444655697.git.lukas@wunner.de> (raw)
In-Reply-To: <1444204528-7870-1-git-send-email-daniel.vetter@ffwll.ch>
This series shows what drm.tmpl would look like if renamed to gpu.tmpl
and amended by the vga_switcheroo documentation. The DocBook would thus
become the "Linux GPU Driver Developer's Guide", covering not only DRM
but also other components in drivers/gpu/.
There are two unsorted lists in the vga_switcheroo documentation which
for optimal rendering require markdown support. One may either apply
the series to drm-next (on top of the markdown patches), or to
drm-intel-nightly (which already has the markdown patches).
The series is also available on GitHub (the commits required for
markdown are apparent from this branch as it's based on drm-next):
https://github.com/l1k/linux/commits/gpu_docs
Best regards,
Lukas
Daniel Vetter (1):
drm/doc: Rename docbook to gpu.tmpl
Lukas Wunner (4):
drm/doc: Remove TODO about drm_vblank_pre/post_modeset()
gpu/doc: Fix up remaining occurrences of old document title
gpu/doc: Add vga_switcheroo documentation
gpu/doc: Convert to markdown harder
Documentation/DocBook/Makefile | 4 +-
Documentation/DocBook/drm.tmpl | 4191 ---------------------------------------
Documentation/DocBook/gpu.tmpl | 4257 ++++++++++++++++++++++++++++++++++++++++
include/drm/drm_vma_manager.h | 2 +-
4 files changed, 4260 insertions(+), 4194 deletions(-)
delete mode 100644 Documentation/DocBook/drm.tmpl
create mode 100644 Documentation/DocBook/gpu.tmpl
--
1.8.5.2 (Apple Git-48)
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2015-10-12 13:31 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-10-07 7:55 [PATCH] [RFC] drm/doc: Rename docbook to gpu.tmpl Daniel Vetter
2015-10-07 14:02 ` Jani Nikula
2015-10-12 13:14 ` Lukas Wunner [this message]
2015-10-07 7:55 ` [PATCH RFC 2/5] " Lukas Wunner
2015-10-10 8:22 ` [PATCH RFC 1/5] drm/doc: Remove TODO about drm_vblank_pre/post_modeset() Lukas Wunner
2015-10-11 9:26 ` [PATCH RFC 3/5] gpu/doc: Fix up remaining occurrences of old document title Lukas Wunner
2015-10-11 9:55 ` [PATCH RFC 4/5] gpu/doc: Add vga_switcheroo documentation Lukas Wunner
2015-10-12 7:10 ` [PATCH RFC 5/5] gpu/doc: Convert to markdown harder Lukas Wunner
2015-10-14 13:59 ` Daniel Vetter
2015-10-14 14:04 ` Danilo Cesar Lemes de Paula
2015-10-14 15:54 ` Lukas Wunner
2015-10-14 17:03 ` Daniel Vetter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1444655697.git.lukas@wunner.de \
--to=lukas@wunner.de \
--cc=daniel.vetter@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox