From: "Noralf Trønnes" <noralf@tronnes.org>
To: Daniel Vetter <daniel.vetter@ffwll.ch>,
DRI Development <dri-devel@lists.freedesktop.org>
Cc: Daniel Vetter <daniel.vetter@intel.com>,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Subject: Re: [PATCH] drm/doc: Task to rename CMA helpers
Date: Tue, 29 Jan 2019 15:42:00 +0100 [thread overview]
Message-ID: <edfe28ef-b710-dce7-fdc8-471057330c18@tronnes.org> (raw)
In-Reply-To: <20190129132153.28844-1-daniel.vetter@ffwll.ch>
Den 29.01.2019 14.21, skrev Daniel Vetter:
> I'm kinda fed up explaining why the have a confusing name :-)
>
> Cc: Noralf Trønnes <noralf@tronnes.org>
> Cc: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
> ---
I agree that it's confusing,
Acked-by: Noralf Trønnes <noralf@tronnes.org>
I would also make sense to fold drm_fb_cma_helper into the cma gem
helper since there's only 2 functions left after my refactorings.
Noralf.
> Documentation/gpu/todo.rst | 10 ++++++++++
> 1 file changed, 10 insertions(+)
>
> diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> index 38360ede1221..17f1cde6adab 100644
> --- a/Documentation/gpu/todo.rst
> +++ b/Documentation/gpu/todo.rst
> @@ -262,6 +262,16 @@ As a reference, take a look at the conversions already completed in drm core.
>
> Contact: Sean Paul, respective driver maintainers
>
> +Rename CMA helpers to DMA helpers
> +---------------------------------
> +
> +CMA (standing for contiguous memory allocator) is really a bit an accident of
> +what these were used for first, a much better name would be DMA helpers. In the
> +text these should even be called coherent DMA memory helpers (so maybd CDM, but
> +no one knows what that means) since underneath they just use dma_alloc_coherent.
> +
> +Contact: Laurent Pinchart, Daniel Vetter
> +
> Core refactorings
> =================
>
>
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2019-01-29 14:42 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-01-29 13:21 [PATCH] drm/doc: Task to rename CMA helpers Daniel Vetter
2019-01-29 14:42 ` Noralf Trønnes [this message]
2019-01-29 18:16 ` Eric Engestrom
2019-01-30 9:03 ` Laurent Pinchart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=edfe28ef-b710-dce7-fdc8-471057330c18@tronnes.org \
--to=noralf@tronnes.org \
--cc=daniel.vetter@ffwll.ch \
--cc=daniel.vetter@intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=laurent.pinchart@ideasonboard.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox