messages from 2026-07-01 11:29:57 to 2026-07-05 00:38:42 UTC [more...]
[PATCH 0/7] rust: Use kernel style vertical imports in various drivers
2026-07-05 0:38 UTC (3+ messages)
[PATCH v2 0/2] Fix sticky -EINVAL after resume callback failure
2026-07-04 5:50 UTC (5+ messages)
` [PATCH v2 1/2] PM: runtime: Only set runtime_error on suspend callback failures
` [PATCH v2 2/2] spi: qcom-geni: Fix missing error check on pm_runtime_get_sync()
[PATCH v1 0/4] gpio: regmap: Keep tracking IRQ requests and releases
2026-07-04 5:21 UTC (13+ messages)
` [PATCH v1 1/4] regmap-irq: Provide IRQ resource request and release callbacks
` [PATCH v1 2/4] gpio: regmap: Provide default "
` [PATCH v1 3/4] gpio: regmap: Apply default resource callbacks for regmap IRQ chip
` [PATCH v1 4/4] gpio: regmap: Order kernel-doc descriptions with the actual appearance
` (subset) [PATCH v1 0/4] gpio: regmap: Keep tracking IRQ requests and releases
[PATCH] rust: io: fix example in `register!` macro
2026-07-03 21:22 UTC (4+ messages)
[PATCH v2] isa: refactor code to remove nested blocks
2026-07-03 21:19 UTC (3+ messages)
[PATCH] rust: irq: make Registration compatible with lifetime-bound drivers
2026-07-03 21:09 UTC
[PATCH v1 0/2] ACPI: bus: Remove struct acpi_driver from the kernel
2026-07-03 20:37 UTC (7+ messages)
` [PATCH v1 1/2] 1/2] ACPI: bus: Eliminate struct acpi_driver
` [PATCH v1 2/2] ACPI: scan: Set power.no_pm for all struct acpi_device objects
[PATCH v2] driver core: add driver name to probe debug print
2026-07-03 16:59 UTC (2+ messages)
[PATCH v5 00/20] rust: I/O type generalization and projection
2026-07-03 15:13 UTC (36+ messages)
` [PATCH v5 01/20] rust: io: add dynamically-sized `Region` type
` [PATCH v5 02/20] rust: io: add missing safety requirement in `IoCapable` methods
` [PATCH v5 07/20] rust: io: implement `Mmio` as view type
` [PATCH v5 09/20] rust: io: use view types instead of addresses for `Io`
` [PATCH v5 10/20] pwm: th1520: remove unnecessary `deref`
` [PATCH v5 11/20] rust: io: remove `MmioOwned`
` [PATCH v5 12/20] rust: io: move `Io` methods to extension trait
` [PATCH v5 13/20] rust: io: add projection macro and methods
` [PATCH v5 14/20] rust: io: add I/O backend for system memory with volatile access
` [PATCH v5 15/20] rust: io: implement a view type for `Coherent`
` [PATCH v5 16/20] rust: io: add `read_val` and `write_val` functions on `Io`
` [PATCH v5 17/20] gpu: nova-core: use I/O projection for cleaner encapsulation
` [PATCH v5 18/20] rust: dma: drop `dma_read!` and `dma_write!` API
[PATCH v3 0/7] Transition Nova Core to TLV firmare images
2026-07-03 13:51 UTC (12+ messages)
` [PATCH v3 1/7] rust: firmware: add request_into_buf()
` [PATCH v3 2/7] gpu: nova-core: add TLV parser for firmware files
` [PATCH v3 3/7] gpu: nova-core: transition booter_load to TLV images
` [PATCH v3 4/7] gpu: nova-core: transition gsp "
` [PATCH v3 5/7] gpu: nova-core: transition gen_bootloader "
` [PATCH v3 6/7] gpu: nova-core: transition fsp "
` [PATCH v3 7/7] gpu: nova-core: update firmware module info for "
[PATCH v3 00/13] arm64: mediatek: Add M.2 E-key slot on Chromebooks
2026-07-03 13:34 UTC (34+ messages)
` [PATCH v3 01/13] device property: Add fwnode_graph_get_port_by_id()
` [PATCH v3 02/13] device property: Add fwnode_graph_get_next_port_endpoint()
` [PATCH v3 03/13] power: sequencing: Add pwrseq_power_is_on()
` [PATCH v3 04/13] usb: hub: Return actual error from hub_configure() in hub_probe()
` [PATCH v3 05/13] usb: hub: Associate port@ fwnode with USB port device
` [PATCH v3 06/13] usb: hub: Pass |struct usb_port*| to usb_port_is_power_on()
` [PATCH v3 07/13] usb: hub: Use usb_hub_set_port_power() to control port power everywhere
` [PATCH v3 08/13] usb: hub: Power on connected M.2 E-key connectors with power sequencing API
` [PATCH v3 09/13] dt-bindings: usb: mediatek,mtk-xhci: Switch to ports for USB connections
` [PATCH v3 10/13] power: sequencing: pcie-m2: support matching on remote "port" node
` [PATCH v3 11/13] power: sequencing: pcie-m2: Add usb and sdio targets for E-key connector
` [PATCH v3 12/13] arm64: dts: mediatek: mt8195-cherry: Add M.2 E-key slot
` [PATCH v3 13/13] arm64: dts: mediatek: mt8188-geralt: Add WiFi/BT as "
[PATCH v2 0/9] treewide, numa_memblks: remove redundant work during NUMA init
2026-07-03 9:43 UTC (4+ messages)
` [PATCH v2 5/9] arch_numa: remove redundant numa_nodes_parsed node_set()
` [PATCH v2 8/9] arch_numa: remove redundant node_possible_map assignment
[GIT PULL] Split <linux/mod_devicetable.h> in per subsystem headers
2026-07-03 7:37 UTC (2+ messages)
[PATCH v5 00/19] rust: drm: Higher-Ranked Lifetime private data
2026-07-03 0:09 UTC (41+ messages)
` [PATCH v5 01/19] rust: drm: ioctl: fix unbounded lifetimes in ioctl handler arguments
` [PATCH v5 02/19] rust: drm: rename Uninit DeviceContext to Normal
` [PATCH v5 03/19] rust: faux: add Device type with AsBusDevice support
` [PATCH v5 04/19] rust: drm: Add Driver::ParentDevice associated type
` [PATCH v5 05/19] rust: drm: change default DeviceContext to Normal
` [PATCH v5 06/19] rust: drm: restrict AlwaysRefCounted to Normal Device context
` [PATCH v5 07/19] rust: drm: restrict AlwaysRefCounted to Normal GEM Object context
` [PATCH v5 08/19] rust: drm/gem: remove DeviceContext from shmem::Object
` [PATCH v5 09/19] rust: drm: split Deref for Device context typestates
` [PATCH v5 10/19] rust: drm: pin ioctl Device reference to Normal context
` [PATCH v5 11/19] rust: drm: add Ioctl device context typestate
` [PATCH v5 12/19] rust: drm: Add RegistrationGuard for drm_dev_enter/exit critical sections
` [PATCH v5 13/19] rust: drm: Wrap ioctl dispatch in RegistrationGuard
` [PATCH v5 14/19] rust: drm: return ParentDevice from Device AsRef
` [PATCH v5 15/19] rust: drm: add AsRef<ParentDevice<Bound>> for Device<Registered>
` [PATCH v5 16/19] drm: fix race between partial drm_dev_register() failure and ioctl
` [PATCH v5 17/19] rust: drm: Add RegistrationData to drm::Driver
` [PATCH v5 18/19] rust: drm: Pass registration data to ioctl handlers
` [PATCH v5 19/19] drm: nova: Use drm::Device<Registered> to access the parent bus device
[RFC PATCH 00/14] driver core: defer per-VF sysfs creation for fast SR-IOV bring-up
2026-07-02 17:51 UTC (15+ messages)
` [RFC PATCH 01/14] kernfs: add populate callbacks and KERNFS_LAZY flag for lazy dir population
` [RFC PATCH 02/14] sysfs: add existence-check helpers for lazy populate races
` [RFC PATCH 03/14] sysfs: introduce sysfs_kf_syscall_ops dispatching to kobj_type
` [RFC PATCH 04/14] driver core: add struct sysfs_lazy_state and device_set_sysfs_lazy()
` [RFC PATCH 05/14] driver core: add struct device_sysfs_entry and walker
` [RFC PATCH 06/14] driver core: wire device_ktype populate to walker
` [RFC PATCH 07/14] driver core: migrate device sysfs to device_sysfs_entry table
` [RFC PATCH 08/14] PCI/sysfs: migrate to device_sysfs_entry, defer physfn symlink
` [RFC PATCH 09/14] iommu: lazy-populate iommu_group reserved_regions/type attrs
` [RFC PATCH 10/14] PCI/IOV: opt SR-IOV VFs into sysfs_lazy
` [RFC PATCH 11/14] vfio: opt vfio-dev and VFIO group devices "
` [RFC PATCH 12/14] driver core: test: add KUnit tests for device_sysfs_apply
` [RFC PATCH 13/14] Documentation: add lazy sysfs initialisation and device_sysfs_entry docs
` [RFC PATCH 14/14] selftests: sysfs-lazy: add tests for lazy sysfs initialization
[PATCH v2 00/11] lib/cpumask: get rid of cpumap_print_to_pagebuf()
2026-07-02 16:21 UTC (15+ messages)
` [PATCH v2 01/11] arm: Use sysfs_emit() for cpumask show callbacks
` [PATCH v2 02/11] powerpc: "
` [PATCH v2 03/11] x86/events: "
` [PATCH v2 04/11] cpu: Use sysfs_emit() for cpumask show callback
` [PATCH v2 05/11] devfreq: Use sysfs_emit() for cpumask show callbacks
` [PATCH v2 06/11] fpga: dfl-fme-perf: Use sysfs_emit() for cpumask show
` [PATCH v2 07/11] hwtracing: hisi_ptt: "
` [PATCH v2 08/11] RDMA/hfi1: Use sysfs_emit() for cpumask show helper
` [PATCH v2 09/11] PCI/sysfs: Use sysfs_emit() for cpumask show callbacks
` [PATCH v2 10/11] perf: "
` [PATCH v2 11/11] lib/bitmap-str: get rid of cpumap_print_to_pagebuf()
[PATCH] driver core: add driver name to probe debug print
2026-07-02 15:53 UTC (4+ messages)
[RFC PATCH 0/3] mm/numa: reserve standby NUMA nodes for runtime claiming
2026-07-02 14:43 UTC (8+ messages)
` [RFC PATCH 1/3] mm/numa: add exclusive node pool and numa=standby boot parameter
[PATCH 0/4] spi: fix sticky -EINVAL after PM runtime resume failure
2026-07-02 14:37 UTC (9+ messages)
` [PATCH 1/4] PM: runtime: Clear runtime_error on supplier after failed get_sync
` [PATCH 2/4] spi: core: fix sticky -EINVAL after pm_runtime_get_sync() failure
` [PATCH 3/4] spi: qcom-geni: Fix missing error check on pm_runtime_get_sync()
` [PATCH 4/4] spi: qcom-geni: fix sticky -EINVAL after PM runtime resume failure
[PATCH] rust: device_id: rename IdTable::as_ptr to as_raw_id_table()
2026-07-02 13:59 UTC (3+ messages)
[PATCH v8 0/8] lan966x pci device: Add support for SFPs, PCI part
2026-07-02 11:23 UTC (4+ messages)
` [PATCH v8 7/8] PCI: of: Set fwnode device of newly created PCI device nodes
[PATCH] rust: devres: fix race between concurrent revokers
2026-07-02 11:10 UTC (6+ messages)
` [PATCH] rust: devres: ensure revocation is complete before device finishes unbinding
[PATCH 0/9] treewide, numa_memblks: remove redundant work during NUMA init
2026-07-02 10:39 UTC (2+ messages)
[PATCH v5 0/2] PM: dpm_watchdog: Improve DPM watchdog configurability
2026-07-02 6:12 UTC (9+ messages)
` [PATCH v5 1/2] PM: sleep: Rename module parameters prefix to "pm_sleep"
` [PATCH v5 2/2] PM: dpm_watchdog: Allow disabling DPM watchdog by default
[PATCH v2 0/7] Transition Nova Core to TLV firmware images
2026-07-02 1:18 UTC (5+ messages)
` [PATCH v2 1/7] rust: firmware: add request_into_buf()
[PATCH 0/4] usb: fix UAF related to dynamic ID
2026-07-01 15:02 UTC (4+ messages)
[PATCH v2 00/19] driver core: count references of the platform device's fwnode, not OF node
2026-07-01 15:05 UTC (5+ messages)
` [PATCH v2 02/19] driver core: platform: provide platform_device_set_of_node()
[PATCH v2 0/7] pci: fix UAF and TOCTOU related to dynamic ID
2026-07-01 13:57 UTC (5+ messages)
` [PATCH v2 4/7] mlxsw: don't keep pci_device_id
` [PATCH v2 7/7] pci: fix UAF when probe runs concurrent to dyn ID removal
[PATCH v18 0/5] shut down devices asynchronously
2026-07-01 13:50 UTC (6+ messages)
` [PATCH 1/5] driver core: separate function to shutdown one device
` [PATCH 2/5] driver core: do not always lock parent in shutdown
` [PATCH 3/5] driver core: async device shutdown infrastructure
` [PATCH 4/5] PCI: Enable async shutdown support
` [PATCH 5/5] scsi: "
[PATCH] sysfs: fix use-after-free in sysfs_create_dir_ns
2026-07-01 13:42 UTC (2+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox