messages from 2026-08-21 03:08:46 to 2026-08-28 01:04:44 UTC [more...]
[PATCH v3 00/16] rust: io: support register projections and remove relative registers
2026-08-28 1:04 UTC (31+ messages)
` [PATCH v3 01/16] rust: io: register: reimplement as proc macro
` [PATCH v3 02/16] rust: mem: add `transmute` with deferred size check
` [PATCH v3 03/16] rust: mem: add `AsRepr` and `AsReprMut`
` [PATCH v3 04/16] rust: io: perform conversions using `AsRepr`
` [PATCH v3 05/16] rust: io: support register projections
` [PATCH v3 06/16] rust: io: register: allow explicit base type specification
` [PATCH v3 07/16] gpu: nova-core: specify base type for registers
` [PATCH v3 09/16] samples: rust: pci: "
` [PATCH v3 10/16] rust: io: register: make register have a typed base
` [PATCH v3 11/16] rust: io: register: support fixed offset register without bitfield
` [PATCH v3 12/16] gpu: nova-core: use projection for PFALCON and PFALCON2 registers
[PATCH v2 0/6] workqueue: OwnedQueue, ScopedQueue and ScopedWork
2026-08-27 23:07 UTC (15+ messages)
` [PATCH v2 1/6] rust: workqueue: replace deprecated system_wq with system_{percpu,dfl}_wq
` [PATCH v2 2/6] rust: workqueue: restrict delayed work to global wqs
` [PATCH v2 3/6] rust: workqueue: create workqueue subdirectory
` [PATCH v2 4/6] rust: workqueue: add creation of workqueues
` [PATCH v2 5/6] rust: workqueue: add ScopedQueue for lifetime bound items
` [PATCH v2 6/6] rust: workqueue: add ScopedWork for non-'static work items
[PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
2026-08-27 14:30 UTC (17+ messages)
` [PATCH 1/2] module: pull out add_taint_module() to be public
` [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
[PATCH v3] arm64: topology: add source check in arch_cpu_idle_enter()
2026-08-27 12:33 UTC (9+ messages)
` [External] "
[PATCH] amba: Fix driver_managed_dma check
2026-08-27 10:13 UTC
[syzbot] [usb?] INFO: task hung in unbind_store
2026-08-27 9:08 UTC (10+ messages)
[syzbot] [kernel?] WARNING: refcount bug in bnep_session (2)
2026-08-27 8:15 UTC (2+ messages)
[PATCH v2] klist: avoid accesses after waking klist_remove()
2026-08-27 4:17 UTC
[PATCH] drivers/base, mm: move arch_numa.c to mm/
2026-08-27 2:49 UTC (2+ messages)
[PATCH v3] driver core: avoid klist_remove() on unattached knode_driver
2026-08-26 21:14 UTC (6+ messages)
` [PATCH v4] "
[syzbot] [kernfs?] possible deadlock in kernfs_link_sibling (2)
2026-08-26 19:33 UTC (2+ messages)
[syzbot] [kernel?] BUG: unable to handle kernel paging request in netdev_unregister_kobject (2)
2026-08-26 17:06 UTC
[syzbot] [kernel?] WARNING: proc registration bug in unregister_irq_proc (2)
2026-08-26 17:01 UTC
[PATCH 1/1] rust: firmware: add the firmware upload abstraction
2026-08-26 16:37 UTC
[PATCH 6/9] rust: io: add checked offset copy helpers
2026-08-26 16:28 UTC
[PATCH] swiotlb: avoid double copy with swiotlb on tx socket
2026-08-26 15:39 UTC (22+ messages)
` [PATCH v2 0/5] swiotlb: avoid swiotlb copy on network sockets
` [PATCH v2 1/5] swiotlb: enforce pool nareas and nslabs invariants
` [PATCH v2 2/5] swiotlb/mm: Implement SWIOTLB nocopy page allocator
` [PATCH v2 3/5] net/swiotlb: Track bounce device per socket
` [PATCH v2 4/5] net: Divert socket allocations to SWIOTLB for nocopy TX
` [PATCH v2 5/5] swiotlb: Implement RX nocopy with fast recycling eviction
` [syzbot ci] Re: swiotlb: avoid swiotlb copy on network sockets
[PATCH v3 0/3] Rust: add runtime PM support
2026-08-26 13:10 UTC (4+ messages)
` [PATCH v3 1/3] rust: "
` [PATCH v3 2/3] rust: platform: wire runtime PM callbacks
` [PATCH v3 3/3 DO NOT MERGE] drm/tyr: enable runtime PM
[PATCH v20 0/8] rust: add `Ownable` trait and `Owned` type
2026-08-26 9:29 UTC (17+ messages)
` [PATCH v20 1/8] rust: alloc: add `KBox::into_non_null`
` [PATCH v20 2/8] rust: types: Add Ownable/Owned types
` [PATCH v20 3/8] rust: implement `ForeignOwnable` for `Owned`
` [PATCH v20 4/8] rust: page: convert to `Ownable`
` [PATCH v20 4/8] rust: page: convert to `Ownable`'
` [PATCH v20 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`
` [PATCH v20 6/8] rust: Add missing SAFETY documentation for `ARef` example
` [PATCH v20 7/8] rust: Add `OwnableRefCounted`
` [PATCH v20 8/8] rust: page: add `from_raw()`
[PATCH v2 00/13] Make SBR work for CXL Downstream Ports
2026-08-26 9:21 UTC (18+ messages)
` [PATCH v2 01/13] cxl/pci: Make the HDM and Mem_Enable writes callable from CXL
` [PATCH v2 02/13] cxl/hdm: Add function to restore one HDM decoder
` [PATCH v2 03/13] cxl/hdm: Add function to restore CXL.mem decode
` [PATCH v2 04/13] cxl/hdm: Reprogram the HDM Decoders below a CXL Port
` [PATCH v2 05/13] cxl/core: Restore the HDM decoders below DPort
` [PATCH v2 06/13] drivers/base/memory: Add cxl_offline_memory() to offline a physical range
` [PATCH v2 07/13] cxl/core: Add region disable and enable for a DPort SBR
` [PATCH v2 08/13] cxl/core: Collect the regions routed through a DPort
` [PATCH v2 09/13] PCI/CXL: Disable and re-enable CXL regions
` [PATCH v2 10/13] PCI/CXL: Clear ACS SV across an SBR of a CXL DPort
` [PATCH v2 11/13] PCI/DPC: Unbind regions for DPC recovery
` [PATCH v2 12/13] PCI/CXL: Add a sysfs entry to unmask SBR
` [PATCH v2 13/13] PCI/CXL: Refuse an SBR of a CXL DPort unless authorized
[PATCH] kobject: avoid blocking allocation while holding uevent_sock_mutex
2026-08-26 7:28 UTC (4+ messages)
[PATCH 0/4] kernfs: remove kernfs_rwsem from dentry revalidation
2026-08-26 4:02 UTC (7+ messages)
` [PATCH 1/4] kernfs: Use VFS lookup context in d_revalidate()
` [PATCH 2/4] kernfs: Prepare directory revisions for lockless reads
` [PATCH 3/4] kernfs: Avoid namespace dereference in d_revalidate()
` [PATCH 4/4] kernfs: Remove kernfs_rwsem from dentry revalidation
[PATCH RFC 00/15] arm-mpam: Add basic device tree support for resctrl
2026-08-25 19:11 UTC (4+ messages)
` [PATCH RFC 02/15] cacheinfo: Expose the code to generate a cache-id from a device_node
[PATCH V2] devtmpfs: restore mount option reconfiguration on get_tree
2026-08-25 14:25 UTC (2+ messages)
[PATCH] kobject: fix out-of-bounds read in action parser
2026-08-25 12:12 UTC (10+ messages)
` "
` [PATCH v2] "
` [PATCH v2 RESEND] kobject: fix out-of-bounds access in kobject_action_type()
[PATCH] klist: avoid accesses after waking klist_remove()
2026-08-25 7:35 UTC (4+ messages)
[PATCH v1 0/2] thermal: core: Revert two cosmetic update that go against driver core changes
2026-08-25 5:55 UTC (4+ messages)
` [PATCH v1 1/2] Revert "thermal/core: Use the thermal class pointer as init guard"
` [PATCH v1 2/2] Revert "thermal/core: Allocate the thermal class dynamically"
[PATCH v1] PM: sleep: Unblock runtime PM when device prepare fails
2026-08-25 2:00 UTC (2+ messages)
[PATCH] thermal: change thermal_class to a const struct
2026-08-24 17:04 UTC (4+ messages)
[syzbot] [usb?] [input?] INFO: task hung in usb_set_configuration
2026-08-24 14:15 UTC
[syzbot] [kernel?] KASAN: global-out-of-bounds Read in uevent_store
2026-08-24 7:30 UTC (6+ messages)
[PATCH 2/2] driver core: power: Fix "sucessfully" typo in comment
2026-08-24 6:34 UTC (2+ messages)
[PATCH] PM: sleep: Add DPM watchdog to late/early/noirq phases
2026-08-24 5:23 UTC (3+ messages)
[PATCH] treewide: Fix typos in comments
2026-08-24 5:10 UTC (2+ messages)
[PATCH] devtmpfs: apply mount options to the existing superblock
2026-08-24 5:08 UTC (2+ messages)
[PATCH v4] driver core: avoid klist_remove() on unattached knode_driver
2026-08-24 4:46 UTC
[PATCH] kernfs: recheck of->released after acquiring the active reference
2026-08-23 12:27 UTC (5+ messages)
` [PATCH v2] "
[syzbot] [kernfs?] possible deadlock in __kernfs_remove (3)
2026-08-23 3:23 UTC (2+ messages)
` [syzbot] [input?] "
[PATCH v2] kernfs: preserve security xattrs without allocating iattrs
2026-08-22 5:17 UTC
[PATCH] kernfs: preserve security xattrs without allocating iattrs
2026-08-21 20:04 UTC (2+ messages)
[PATCH v20 0/9] shut down devices asynchronously
2026-08-21 14:24 UTC (10+ messages)
` [PATCH 1/9] driver core: rely on put_device to free dev->p
` [PATCH 2/9] driver core: prevent device_add() during system shutdown
` [PATCH 3/9] driver core: warn should device_move try to move a need_parent_lock device
` [PATCH 4/9] driver core: separate function to shutdown one device
` [PATCH 5/9] driver core: do not always lock parent in shutdown
` [PATCH 6/9] driver core: async device shutdown infrastructure
` [PATCH 7/9] PCI: Link a virtual function to its physical function
` [PATCH 8/9] PCI: Enable async shutdown support
` [PATCH 9/9] scsi: "
[PATCH net-next v3 0/4] driver core, net: handle fw_devlink for class devices and PHY packages
2026-08-21 5:05 UTC (4+ messages)
` [PATCH net-next v3 4/4] driver core: handle managed links for class devices
[PATCH v3 0/4] device_schedule_reprobe(): core helper and conversions
2026-08-21 3:08 UTC (4+ messages)
` [PATCH v3 2/4] wifi: iwlwifi: use device_schedule_reprobe()
` [PATCH v3 3/4] Bluetooth: hci_h5: "
` [PATCH v3 4/4] Bluetooth: btintel_pcie: use device_schedule_reprobe() after reset
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox