From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mx1.redhat.com ([209.132.183.28]:39438 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932872AbcLHEAy (ORCPT ); Wed, 7 Dec 2016 23:00:54 -0500 Date: Thu, 8 Dec 2016 12:00:43 +0800 From: Eryu Guan Subject: Re: [PATCH 1/2] fstests: common: rename and enhance _require_btrfs to _require_btrfs_subcommand Message-ID: <20161208040043.GE29149@eguan.usersys.redhat.com> References: <20161208020456.16116-1-quwenruo@cn.fujitsu.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20161208020456.16116-1-quwenruo@cn.fujitsu.com> Sender: fstests-owner@vger.kernel.org To: Qu Wenruo Cc: linux-btrfs@vger.kernel.org, fstests@vger.kernel.org List-ID: On Thu, Dec 08, 2016 at 10:04:55AM +0800, Qu Wenruo wrote: > Rename _require_btrfs() to _require_btrfs_subcommand() to avoid > confusion, as all other _require_btrfs_* has a quite clear suffix, like > _require_btrfs_mkfs_feature() or _require_btrfs_fs_feature(). > > Also enhance _require_btrfs_subcommand() to accept 2nd level commands or > options. > Options will be determined by the first "-" char. > This is quite useful for case like "btrfs inspect-internal dump-tree" > and "btrfs check --qgroup-report". > > Signed-off-by: Qu Wenruo > --- > common/rc | 29 ++++++++++++++++++++++++----- Can you rebase on top of current master please? We've moved btrfs-specific functions to common/btrfs > tests/btrfs/004 | 3 ++- > tests/btrfs/048 | 2 +- > tests/btrfs/059 | 2 +- > tests/btrfs/131 | 2 +- > 5 files changed, 29 insertions(+), 9 deletions(-) > > diff --git a/common/rc b/common/rc > index 8c99306..1703232 100644 > --- a/common/rc > +++ b/common/rc > @@ -3019,15 +3019,34 @@ _require_deletable_scratch_dev_pool() > } > > # We check for btrfs and (optionally) features of the btrfs command > -_require_btrfs() > +# _require_btrfs_subcommand [|