From: Brad Roberts <braddr@gameboy2.puremagic.com>
To: git@vger.kernel.org
Subject: [PATCH 00/19] summary of patch set
Date: Thu, 21 Apr 2005 11:34:26 -0700 [thread overview]
Message-ID: <200504211834.j3LIYQuc026089@gameboy2.puremagic.com> (raw)
Tonight I did a bunch of tiny steps towards making the cache management
code behave more like a library. There are no longer any global variables
in read-cache.c. Nothing ever uses more than one cache yet, but I can
see how it might simplify some of the merge code.
They're also visible here: http://gameboy2.puremagic.com:8090/
[PATCH 01/19] write_cache api signature change, isolate active_cache and active_nr inside read-cache.c
[PATCH 02/19] Add new api's to front the active_cache and active_nr cache internals
[PATCH 03/19] convert show-diff.c to use new cache hiding api's
[PATCH 04/19] Migrate update-cache.c to use the new cache api's
[PATCH 05/19] migrate checkout-cache.c to the new cache api's
[PATCH 06/19] migrate show-files.c to the new cache api's
[PATCH 07/19] migrate merge-cache.c over to the new cache api's
[PATCH 08/19] rename remove_entry_at to remove_cache_entry_at and expose as a public api
[PATCH 09/19] migrate read-tree.c to the new cache api's
[PATCH 10/19] migrate check-files.c to the new cache api's
[PATCH 11/19] migrate write-tree.c to use the new cache api's
[PATCH 12/19] fix up diff-cache.c to use new cache api's
[PATCH 13/19] Remove active_cache, active_nr, and active_alloc from public view
[PATCH 14/19] move cache_header out of the public view
[PATCH 15/19] introduce a cache struct and move the various cache globals into it.
[PATCH 16/19] change all call sites that use the return value of read_cache to get the # of cache entries.
[PATCH 17/19] temporarily change add_cache_entry to create an empty cache on demand
[PATCH 18/19] rename cache_match_stat to ce_match_stat to match other cache_entry related functions/macros
[PATCH 19/19] the end goal of the last dozen or so commits, there's no longer a global cache variable
[PATCH 01-19/19] All of the above combined
reply other threads:[~2005-04-21 18:30 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200504211834.j3LIYQuc026089@gameboy2.puremagic.com \
--to=braddr@gameboy2.puremagic.com \
--cc=git@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox