Git development
 help / color / mirror / Atom feed
From: Eric Wong <normalperson@yhbt.net>
To: Johannes Schindelin <Johannes.Schindelin@gmx.de>
Cc: Nicolas Pitre <nico@cam.org>,
	git@vger.kernel.org, Simon Josefsson <simon@josefsson.org>,
	junkio@cox.net
Subject: Re: [PATCH] Add --pretty=changelog
Date: Tue, 27 Feb 2007 15:11:00 -0800	[thread overview]
Message-ID: <20070227231100.GA25782@localdomain> (raw)
In-Reply-To: <Pine.LNX.4.63.0702271656540.22628@wbgn013.biozentrum.uni-wuerzburg.de>

Johannes Schindelin <Johannes.Schindelin@gmx.de> wrote:
> Hi,
> 
> On Tue, 27 Feb 2007, Nicolas Pitre wrote:
> 
> > On Tue, 27 Feb 2007, Johannes Schindelin wrote:
> > 
> > > 
> > > This outputs the log in GNU ChangeLog format.
> > 
> > Please don't call it "changelog".  I personally find this format horrid 
> > and "changelog" is too generic for such a specific format.  
> > "gnu_changelog" maybe...
> 
> Fair enough. Maybe with a dash, so it is easier to type?

> --- a/commit.c
> +++ b/commit.c
> @@ -38,6 +38,7 @@ struct cmt_fmt_map {
>  	{ "fuller",	5,	CMIT_FMT_FULLER },
>  	{ "oneline",	1,	CMIT_FMT_ONELINE },
>  	{ "format:",	7,	CMIT_FMT_USERFORMAT},
> +	{ "changelog",	9,	CMIT_FMT_CHANGELOG}
                        ^- that should be a 1

'gnu[_-]changelog' or 'changelog' would all uniquely abbreviate to a
single character.

--pretty=gnu sounds nice, however :)

-- 
Eric Wong

  reply	other threads:[~2007-02-27 23:11 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <Pine.LNX.4.63.0702271621120.22628@wbgn013.biozentrum.uni-wuerz burg.de>
2007-02-27 15:21 ` [PATCH] Add --pretty=changelog Johannes Schindelin
2007-02-27 15:38   ` Nicolas Pitre
2007-02-27 15:57     ` Johannes Schindelin
2007-02-27 23:11       ` Eric Wong [this message]
2007-02-27 23:22         ` Junio C Hamano
2007-02-28  1:58   ` [PATCH 4/3] Rename --pretty=changelog to --pretty=gnucl, and fix a bug Johannes Schindelin
2007-02-28  2:52     ` Nicolas Pitre
2007-02-28 12:44       ` [PATCH] --amend Rename --pretty=changelog to --pretty=gnucl Johannes Schindelin
2007-03-02  8:49         ` Junio C Hamano
2007-03-02 14:28           ` [PATCH] print_wrapped_text: fix output for negative indent Johannes Schindelin
2007-03-02 14:29           ` [PATCH] --pretty=gnucl: avoid line wrapping before the comma Johannes Schindelin
2007-03-03 12:38           ` [PATCH] --amend Rename --pretty=changelog to --pretty=gnucl Junio C Hamano
2007-03-03 14:13             ` Johannes Schindelin
2007-03-03 20:07               ` Junio C Hamano
2007-03-01 15:23   ` [PATCH] Add --pretty=changelog Simon Josefsson
2007-03-01 18:15     ` Johannes Schindelin
2007-03-01 18:27       ` Shawn O. Pearce
2007-03-01 18:40         ` Johannes Schindelin
2007-03-02  4:39       ` Junio C Hamano
2007-03-02  9:14       ` Simon Josefsson
2007-03-02 10:03         ` Junio C Hamano
2007-03-02 10:15           ` Simon Josefsson
2007-03-02 14:09         ` Johannes Schindelin
2007-03-03 14:12           ` Simon Josefsson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20070227231100.GA25782@localdomain \
    --to=normalperson@yhbt.net \
    --cc=Johannes.Schindelin@gmx.de \
    --cc=git@vger.kernel.org \
    --cc=junkio@cox.net \
    --cc=nico@cam.org \
    --cc=simon@josefsson.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox