From: Robin Rosenberg <robin.rosenberg.lists@dewire.com>
To: "Shawn O. Pearce" <spearce@spearce.org>
Cc: git@vger.kernel.org
Subject: Re: [JGIT PATCH] Rename RevTag.getName() to RevTag.getTagName()
Date: Wed, 12 Aug 2009 22:37:36 +0200 [thread overview]
Message-ID: <200908122237.37148.robin.rosenberg.lists@dewire.com> (raw)
In-Reply-To: <1250105956-17795-1-git-send-email-spearce@spearce.org>
onsdag 12 augusti 2009 21:39:16 skrev "Shawn O. Pearce" <spearce@spearce.org>:
> The method getName() conflicts semantically with the method name()
> we have inherited from our base class, ObjectId. It is a rather
> unfortunate turn of events that for performance reasons we wind up
> subclassing what should be a property of this class, but since we
> do that we need to pay attention to the methods declared on our
> base class.
>
> We want to use getName() to be a mirror of name() on AnyObjectId,
> as it has a more JavaBeans style feel to the accessing of that
> particular value. So, rename getTagName() so it doesn't wind up
> conflicting with the SHA-1 hex formatted string.
> @@ -204,7 +204,7 @@ public final RevObject getObject() {
> * @return name of the tag, according to the tag header.
> */
> public final String getName() {
> - return name;
> + return tagName;
> }
>
> final void disposeBody() {
You forgot the rename of the method here, and all uses of it.
-- robin
next prev parent reply other threads:[~2009-08-12 20:37 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-08-12 19:39 [JGIT PATCH] Rename RevTag.getName() to RevTag.getTagName() Shawn O. Pearce
2009-08-12 20:37 ` Robin Rosenberg [this message]
2009-08-12 20:51 ` [JGIT PATCH v2] " Shawn O. Pearce
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200908122237.37148.robin.rosenberg.lists@dewire.com \
--to=robin.rosenberg.lists@dewire.com \
--cc=git@vger.kernel.org \
--cc=spearce@spearce.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox