From: Adam Spiers <git@adamspiers.org>
To: git list <git@vger.kernel.org>
Subject: Re: [PATCH v3 11/19] dir.c: use a single struct exclude_list per source of excludes
Date: Sun, 6 Jan 2013 23:17:57 +0000 [thread overview]
Message-ID: <20130106231757.GA19655@pacific.linksys.moosehall> (raw)
In-Reply-To: <20130106225311.GB6552@pacific.linksys.moosehall>
On Sun, Jan 06, 2013 at 10:53:11PM +0000, Adam Spiers wrote:
> That's a valid point. However, the ary[0] part which assumes external
> knowledge of the internal implementation can trivially be avoided by
> squashing this patch onto the commit we are discussing:
[snipped]
> diff --git a/builtin/ls-files.c b/builtin/ls-files.c
> index 0ca9d8e..0406adc 100644
> --- a/builtin/ls-files.c
> +++ b/builtin/ls-files.c
> @@ -420,10 +420,11 @@ static int option_parse_z(const struct option *opt,
> static int option_parse_exclude(const struct option *opt,
> const char *arg, int unset)
> {
> - struct exclude_list_group *group = opt->value;
> + struct string_list *exclude_list = opt->value;
>
> exc_given = 1;
> - add_exclude(arg, "", 0, &group->el[0]);
> + string_list_append(exclude_list, arg);
> + fprintf(stderr, "append %s\n", arg);
Whoops :-)
[snipped]
> @@ -524,9 +527,13 @@ int cmd_ls_files(int argc, const char **argv, const char *cmd_prefix)
> if (read_cache() < 0)
> die("index file corrupt");
>
> - add_exclude_list(&dir, EXC_CMDL);
> argc = parse_options(argc, argv, prefix, builtin_ls_files_options,
> ls_files_usage, 0);
> + el = add_exclude_list(&dir, EXC_CMDL);
> + for (i = 0; i < exclude_list.nr; i++) {
> + fprintf(stderr, "adding exclude: %s\n", exclude_list.items[i].string);
Excluding those two fprintf() calls, of course :-)
I've removed them, and pushed to my github fork a new version of v4
with the fixed version of this patch inserted in the appropriate place
(and labelled with a "[SQUASH]" prefix):
git://github.com/aspiers/git.git
https://github.com/aspiers/git/commits/check-ignore
Since I sent v4 earlier today, to avoid spamming this list, I won't
resend the whole series yet - not until we have made some progress in
reviewing v4.
next prev parent reply other threads:[~2013-01-06 23:18 UTC|newest]
Thread overview: 55+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-12-27 2:32 [PATCH v3 00/19] new git check-ignore sub-command Adam Spiers
2012-12-27 2:32 ` [PATCH v3 01/19] api-directory-listing.txt: update to match code Adam Spiers
2012-12-27 2:32 ` [PATCH v3 02/19] Improve documentation and comments regarding directory traversal API Adam Spiers
2013-01-01 20:52 ` Junio C Hamano
2013-01-02 12:54 ` Adam Spiers
2013-01-06 12:02 ` Adam Spiers
2012-12-27 2:32 ` [PATCH v3 03/19] dir.c: rename cryptic 'which' variable to more consistent name Adam Spiers
2012-12-27 2:32 ` [PATCH v3 04/19] dir.c: rename path_excluded() to is_path_excluded() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 05/19] dir.c: rename excluded_from_list() to is_excluded_from_list() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 06/19] dir.c: rename excluded() to is_excluded() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 07/19] dir.c: refactor is_excluded_from_list() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 08/19] dir.c: refactor is_excluded() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 09/19] dir.c: refactor is_path_excluded() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 10/19] dir.c: rename free_excludes() to clear_exclude_list() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 11/19] dir.c: use a single struct exclude_list per source of excludes Adam Spiers
2013-01-04 21:03 ` Junio C Hamano
2013-01-05 7:54 ` Junio C Hamano
2013-01-06 15:27 ` Adam Spiers
2013-01-06 15:35 ` [PATCH] api-allocation-growing.txt: encourage better variable naming Adam Spiers
2013-01-06 20:29 ` Junio C Hamano
2013-01-06 20:52 ` Adam Spiers
2013-01-06 20:58 ` Junio C Hamano
2013-01-06 15:20 ` [PATCH v3 11/19] dir.c: use a single struct exclude_list per source of excludes Adam Spiers
2013-01-06 20:25 ` Junio C Hamano
2013-01-06 22:53 ` Adam Spiers
2013-01-06 23:17 ` Adam Spiers [this message]
2013-01-06 23:19 ` Junio C Hamano
2012-12-27 2:32 ` [PATCH v3 12/19] dir.c: keep track of where patterns came from Adam Spiers
2012-12-27 2:32 ` [PATCH v3 13/19] dir.c: provide clear_directory() for reclaiming dir_struct memory Adam Spiers
2012-12-27 2:32 ` [PATCH v3 14/19] add.c: refactor treat_gitlinks() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 15/19] add.c: remove unused argument from validate_pathspec() Adam Spiers
2012-12-27 2:32 ` [PATCH v3 16/19] pathspec.c: move reusable code from builtin/add.c Adam Spiers
2012-12-28 20:32 ` Junio C Hamano
2012-12-28 20:45 ` Adam Spiers
2012-12-29 0:40 ` Adam Spiers
2012-12-28 20:48 ` Junio C Hamano
2012-12-28 21:15 ` Adam Spiers
2012-12-27 2:32 ` [PATCH v3 17/19] pathspec.c: extract new validate_path() for reuse Adam Spiers
2012-12-28 20:44 ` Junio C Hamano
2012-12-28 21:08 ` Adam Spiers
2012-12-27 2:32 ` [PATCH v3 18/19] setup.c: document get_pathspec() Adam Spiers
2012-12-28 20:36 ` Junio C Hamano
2012-12-28 20:40 ` Adam Spiers
2012-12-29 0:52 ` Adam Spiers
2012-12-29 1:36 ` Junio C Hamano
2012-12-27 2:32 ` [PATCH v3 19/19] Add git-check-ignore sub-command Adam Spiers
2012-12-28 21:21 ` Junio C Hamano
2012-12-29 1:23 ` Adam Spiers
2012-12-29 3:32 ` Adam Spiers
2012-12-27 5:15 ` [PATCH v3 00/19] new git check-ignore sub-command Michael Leal
2012-12-28 18:50 ` Junio C Hamano
2012-12-28 19:39 ` Adam Spiers
2012-12-28 20:15 ` Antoine Pelisse
2012-12-28 21:31 ` Junio C Hamano
2012-12-28 21:23 ` Junio C Hamano
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130106231757.GA19655@pacific.linksys.moosehall \
--to=git@adamspiers.org \
--cc=git@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox