Git development
 help / color / mirror / Atom feed
From: Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
To: Patrick Steinhardt <ps@pks.im>
Cc: git@vger.kernel.org, Karthik Nayak <karthik.188@gmail.com>,
	Junio C Hamano <gitster@pobox.com>
Subject: Re: [PATCH v2 01/11] builtin/init: rename "--ref-format=" to "--ref-storage-format="
Date: Wed, 9 Sep 2026 14:44:43 +0530	[thread overview]
Message-ID: <472d9d2b-efea-48a9-98f0-02364b1a9ccf@gmail.com> (raw)
In-Reply-To: <aqED9Xn6xibcp9pf@pks.im>

On 9/9/26 12:30, Patrick Steinhardt wrote:
> On Tue, Sep 08, 2026 at 02:31:22PM +0530, Kaartic Sivaraam wrote:
> 
> I'm aiming for a a quiet deprecation -- the old options keep on working,
> but we don't show them anymore. We may eventually remove them
> altogether, but I neither want to warn about use of old options now or
> even remove them as that would likely cause more negative consequences
> than is worth it. It's not like we want to soon use the old names.
> 

Understood.

> 
> But I agree that we should keep the old options documented. Otherwise,
> it might be hard to figure out what those options do in case they for
> example still exist in an old script.
> 

Yeah, makes sense.

>>
>> Relevant only if we are deprecating the old option: We could change the
>> description of the old option to convey that it is deprecated so that it
>> could be easily distinguished by anyone reading through. I suggest this by
>> noting a similar pattern in `builtin/name-rev.c` for the `--stdin` argument.
> 
> We don't really have to update the description as we pass
> `PARSE_OPT_HIDDEN` anyway, so the option is not even shown.
>

Indeed. I was suggesting to change the description only for the sake of 
someone who reads the code to quickly get an idea that we have 
deprecated the old names. The PARSE_OPT_HIDDEN would definitely hint at 
it but this just a suggestion to make it more obvious :-)

That said, it's fine if we don't change the description too. It isn't a 
big deal.

>> If we don't plan to deprecate, I suppose we could use OPT_ALIAS to clarify
>> that `ref-format` is an alias of `ref-storage-format` similar to how
>> `recursive` is marked as an alias of `recurse-submodules` in
>> `builtin/clone.c`.
> 
> I was originally planning to use `OPT_ALIAS()`, but we don't seem to
> support `PARSE_OPT_HIDDEN` there. Maybe it's better to add a small
> preparatory patch to support that though.
> 

Indeed. OPT_ALIAS does have that caveat. A patch to allow the alias to 
be hidden by choice would indeed be worthwhile.

-- 
Sivaraam


  reply	other threads:[~2026-09-09  9:14 UTC|newest]

Thread overview: 61+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-04 10:36 [PATCH 00/11] Fix inconsistent ref storage format terminology Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 01/11] builtin/init: rename "--ref-format=" to "--ref-storage=" Patrick Steinhardt
2026-09-04 13:05   ` Karthik Nayak
2026-09-07 10:00     ` Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 02/11] builtin/clone: " Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 03/11] builtin/refs: " Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 04/11] builtin/submodule: " Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 05/11] builtin/rev-parse: rename "--show-ref-format" to "--show-ref-storage" Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 06/11] help: rename "default-ref-format" to "default-ref-storage" Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 07/11] refs: expose function to parse reference URIs Patrick Steinhardt
2026-09-04 13:12   ` Karthik Nayak
2026-09-04 10:36 ` [PATCH 08/11] setup: refactor how we configure the ref storage format Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 09/11] setup: rename ref storage format environment variables Patrick Steinhardt
2026-09-04 13:20   ` Karthik Nayak
2026-09-07 10:00     ` Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 10/11] setup: rename "init.defaultRefFormat" to "init.defaultRefStorage" Patrick Steinhardt
2026-09-04 10:36 ` [PATCH 11/11] setup: allow "git init --ref-storage=" to specify a payload Patrick Steinhardt
2026-09-04 13:23 ` [PATCH 00/11] Fix inconsistent ref storage format terminology Karthik Nayak
2026-09-04 17:15 ` Junio C Hamano
2026-09-07 10:00   ` Patrick Steinhardt
2026-09-07 11:18 ` [PATCH v2 " Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 01/11] builtin/init: rename "--ref-format=" to "--ref-storage-format=" Patrick Steinhardt
2026-09-08  9:01     ` Kaartic Sivaraam
2026-09-09  7:00       ` Patrick Steinhardt
2026-09-09  9:14         ` Kaartic Sivaraam [this message]
2026-09-07 11:18   ` [PATCH v2 02/11] builtin/clone: " Patrick Steinhardt
2026-09-08  9:21     ` Kaartic Sivaraam
2026-09-09  7:03       ` Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 03/11] builtin/refs: " Patrick Steinhardt
2026-09-08 10:55     ` Kaartic Sivaraam
2026-09-09  7:03       ` Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 04/11] builtin/submodule: " Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 05/11] builtin/rev-parse: rename "--show-ref-format" to "--show-ref-storage-format" Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 06/11] help: rename "default-ref-format" to "default-ref-storage-format" Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 07/11] refs: expose function to parse reference URIs Patrick Steinhardt
2026-09-08 13:47     ` Kaartic Sivaraam
2026-09-09  7:03       ` Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 08/11] setup: refactor how we configure the ref storage format Patrick Steinhardt
2026-09-09  8:00     ` Kaartic Sivaraam
2026-09-09  9:23       ` Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 09/11] setup: rename ref storage format environment variables Patrick Steinhardt
2026-09-09  8:10     ` Kaartic Sivaraam
2026-09-09  9:23       ` Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 10/11] setup: rename "init.defaultRefFormat" to "init.defaultRefStorageFormat" Patrick Steinhardt
2026-09-07 11:18   ` [PATCH v2 11/11] setup: allow "git init --ref-storage-format=" to specify a payload Patrick Steinhardt
2026-09-09  8:54     ` Kaartic Sivaraam
2026-09-09  9:23       ` Patrick Steinhardt
2026-09-09 11:12 ` [PATCH v3 00/13] Fix inconsistent ref storage format terminology Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 01/13] parse-options: allow for hidden aliases Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 02/13] builtin/init: rename "--ref-format=" to "--ref-storage-format=" Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 03/13] builtin/clone: " Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 04/13] builtin/refs: " Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 05/13] builtin/submodule: " Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 06/13] builtin/rev-parse: rename "--show-ref-format" to "--show-ref-storage-format" Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 07/13] help: rename "default-ref-format" to "default-ref-storage-format" Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 08/13] refs: expose function to parse reference URIs Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 09/13] setup: refactor how we configure the ref storage format Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 10/13] setup: rename ref storage format environment variables Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 11/13] t: rename GIT_TEST_DEFAULT_REF_FORMAT Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 12/13] setup: rename "init.defaultRefFormat" to "init.defaultRefStorageFormat" Patrick Steinhardt
2026-09-09 11:12   ` [PATCH v3 13/13] setup: allow "--ref-storage-format=" to specify a payload Patrick Steinhardt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=472d9d2b-efea-48a9-98f0-02364b1a9ccf@gmail.com \
    --to=kaartic.sivaraam@gmail.com \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=karthik.188@gmail.com \
    --cc=ps@pks.im \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox