From mboxrd@z Thu Jan 1 00:00:00 1970 From: Junio C Hamano Subject: Re: [PATCH] block-sha1: Windows declares ntohl() in winsock2.h Date: Tue, 18 Aug 2009 13:30:34 -0700 Message-ID: <7v7hx0c1at.fsf@alter.siamese.dyndns.org> References: <4A8A552D.6020407@viscovery.net> <4A8A8661.5060908@gmail.com> <4A8AA511.1060205@gmail.com> <7v4os5gs0p.fsf@alter.siamese.dyndns.org> <7vpratdpc8.fsf@alter.siamese.dyndns.org> <7vprasc1vu.fsf@alter.siamese.dyndns.org> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Cc: Nicolas Pitre , Sebastian Schuberth , Artur Skawina , Johannes Sixt , msysGit , Linus Torvalds , Git Mailing List To: Junio C Hamano X-From: git-owner@vger.kernel.org Tue Aug 18 22:30:58 2009 Return-path: Envelope-to: gcvg-git-2@lo.gmane.org Received: from vger.kernel.org ([209.132.176.167]) by lo.gmane.org with esmtp (Exim 4.50) id 1MdVKY-0006Fl-PU for gcvg-git-2@lo.gmane.org; Tue, 18 Aug 2009 22:30:55 +0200 Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751826AbZHRUar (ORCPT ); Tue, 18 Aug 2009 16:30:47 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1751739AbZHRUaq (ORCPT ); Tue, 18 Aug 2009 16:30:46 -0400 Received: from a-pb-sasl-quonix.pobox.com ([208.72.237.25]:61827 "EHLO sasl.smtp.pobox.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751461AbZHRUaq (ORCPT ); Tue, 18 Aug 2009 16:30:46 -0400 Received: from a-pb-sasl-quonix. (unknown [127.0.0.1]) by a-pb-sasl-quonix.pobox.com (Postfix) with ESMTP id 7C8C6FF02; Tue, 18 Aug 2009 16:30:47 -0400 (EDT) Received: from pobox.com (unknown [68.225.240.211]) (using TLSv1 with cipher DHE-RSA-AES128-SHA (128/128 bits)) (No client certificate requested) by a-pb-sasl-quonix.pobox.com (Postfix) with ESMTPSA id 3F88DFF01; Tue, 18 Aug 2009 16:30:36 -0400 (EDT) In-Reply-To: <7vprasc1vu.fsf@alter.siamese.dyndns.org> (Junio C. Hamano's message of "Tue\, 18 Aug 2009 13\:17\:57 -0700") User-Agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux) X-Pobox-Relay-ID: 030CB52A-8C36-11DE-956F-EAC21EFB4A78-77302942!a-pb-sasl-quonix.pobox.com Sender: git-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: git@vger.kernel.org Archived-At: Junio C Hamano writes: > Nicolas Pitre writes: > >> On Tue, 18 Aug 2009, Junio C Hamano wrote: >> >>> To reduce confusion, you may want to rename compat/bswap.h to something >>> like compat/ntohl-htonl-fix.h ;-) >> >> Bah. If you wish, you can edit the patch directly for this, unless you >> really prefer me to repost. Maybe we might want to add a 8-byte >> versions of those as well eventually, which is why I chose a more >> generic name. > > Ok, here is what I came up with after many squashing... Meh, our mails crossed. I'll chuck this one and use your [PATCH] make sure byte swapping is optimal for git patch. Do you want default_swab32 be mmoved inside the #if defined(__GNUC__) && (defined(__i386__) || defined(__x86_64__)) block?