messages from 2026-09-08 19:45:02 to 2026-09-10 14:27:00 UTC [more...]
[PATCH 0/8] odb: write alternates at creation time
2026-09-10 14:26 UTC (22+ messages)
` [PATCH v4 0/9] "
` [PATCH v4 1/9] setup: split up concerns of `init_db()`
` [PATCH v4 2/9] builtin/clone: defer setup of the object database
` [PATCH v4 3/9] builtin/clone: move around `setup_reference()`
` [PATCH v4 4/9] builtin/clone: refactor handling of "--reference{,-if-able}"
` [PATCH v4 5/9] builtin/clone: move setup of alternates for shared local clones
` [PATCH v4 6/9] builtin/clone: move setup of alternates for non-shared "
` [PATCH v4 7/9] odb/source: support writing alternates when creating the database
` [PATCH v4 8/9] builtin/clone: write alternates via `odb_create_on_disk()`
` [PATCH v4 9/9] odb/source: remove the ability to write alternates
[PATCH] hook: introduce the report hook for git-receive-pack(1)
2026-09-10 13:43 UTC (11+ messages)
` [PATCH v9 0/4] hook: introduce the receive-report hook
` [PATCH v9 1/4] doc: add proc-receive hook info in 'git-receive-pack.adoc'
` [PATCH v9 2/4] receive-pack: drop static variables to track report status version
` [PATCH v9 3/4] receive-pack: move message generation to separate function
` [PATCH v9 4/4] hook: introduce the receive-report hook
[PATCH] builtin/history: unuse the commit buffer after use
2026-09-10 13:36 UTC (3+ messages)
` [PATCH v2] "
[PATCH 00/12] Upstream some more Git for Windows' patches
2026-09-10 12:51 UTC (38+ messages)
` [PATCH v2 "
` [PATCH v2 08/12] mingw: rely on MSYS2's metadata instead of hard-coding it
` [PATCH v3 00/12] Upstream some more Git for Windows' patches
` [PATCH v3 01/12] mingw: include the Python parts in the build
` [PATCH v3 02/12] mingw: stop hard-coding `CC = gcc`
` [PATCH v3 03/12] mingw: drop the -D_USE_32BIT_TIME_T option
` [PATCH v3 04/12] mingw: only use -Wl,--large-address-aware for 32-bit builds
` [PATCH v3 05/12] mingw: avoid over-specifying `--pic-executable`
` [PATCH v3 06/12] mingw: set the prefix and HOST_CPU as per MSYS2's settings
` [PATCH v3 07/12] mingw: only enable the MSYS2-specific stuff when compiling in MSYS2
` [PATCH v3 08/12] mingw: rely on MSYS2's metadata instead of hard-coding it
` [PATCH v3 09/12] windows: skip linking `git-<command>` for built-ins
` [PATCH v3 10/12] mingw: always define `ETC_*` for MSYS2 environments
` [PATCH v3 11/12] mingw: ensure valid CTYPE
` [PATCH v3 12/12] mingw: allow `git.exe` to be used instead of the "Git wrapper"
` [PATCH v4 00/13] Upstream some more Git for Windows' patches
` [PATCH v4 01/13] mingw: include the Python parts in the build
` [PATCH v4 02/13] mingw: stop hard-coding `CC = gcc`
` [PATCH v4 03/13] mingw: drop the -D_USE_32BIT_TIME_T option
` [PATCH v4 04/13] mingw: only use -Wl,--large-address-aware for 32-bit builds
` [PATCH v4 05/13] mingw: avoid over-specifying `--pic-executable`
` [PATCH v4 06/13] mingw: set the prefix and HOST_CPU as per MSYS2's settings
` [PATCH v4 07/13] mingw: only enable the MSYS2-specific stuff when compiling in MSYS2
` [PATCH v4 08/13] mingw: rely on MSYS2's metadata instead of hard-coding it
` [PATCH v4 09/13] windows: skip linking `git-<command>` for built-ins
` [PATCH v4 10/13] mingw: always define `ETC_*` for MSYS2 environments
` [PATCH v4 11/13] mingw: ensure valid CTYPE
` [PATCH v4 12/13] mingw: allow `git.exe` to be used instead of the "Git wrapper"
` [PATCH v4 13/13] t0060: adjust the code style
[PATCH v2] Move rust gitcore crate to a different subdirectory
2026-09-10 12:21 UTC (9+ messages)
` [PATCH v3] "
` [PATCH v4] "
[PATCH] advice: use global config for default branch name
2027-08-29 0:59 UTC (12+ messages)
[PATCH] rust: respect CARGO_BUILD_TARGET when locating build output
2026-09-10 10:20 UTC (4+ messages)
` [PATCH v2] "
` [PATCH v3] "
[PATCH v3] advice: use global config for default branch name
2027-08-29 0:49 UTC (13+ messages)
` [PATCH v4 0/3] defaultBranchName advice is useless
` [PATCH v4 1/3] advice: pass the entire advice_setting to vadvise()
` [PATCH v4 2/3] advice: introduce advice scoping mechanism
` [PATCH v4 3/3] advice: use global config for default branch name
[PATCH] refs/files: avoid packed-refs lock for root ref deletion
2026-09-10 8:35 UTC (2+ messages)
[PATCH] push: fix --force-if-includes when remote-tracking ref has no reflog
2026-09-10 8:31 UTC (10+ messages)
` [PATCH v2] "
[PATCH 0/2] sequencer: leave auto maintenance to the end of a rebase
2026-09-10 8:25 UTC (10+ messages)
` [PATCH v3 0/3] sequencer: leave auto maintenance to the end of a sequence
` [PATCH v4 "
` [PATCH v4 1/3] config: add git_config_append_parameter()
` [PATCH v4 2/3] rebase, cherry-pick, revert: run auto maintenance when done
` [PATCH v4 3/3] sequencer: disable auto maintenance in spawned commands
[PATCH] doc: Make asciidoc bullet items separate
2026-09-10 8:17 UTC (3+ messages)
` [PATCH v2] doc: fix conjoined maintenance strategies in git-config(1)
[PATCH v4 0/6] last-modified: use the pathspec's Bloom key to pre-filter commits
2026-09-10 7:04 UTC (9+ messages)
` [PATCH v4 3/6] bloom: add helper to check if any key in a vector is present
` [PATCH v4 4/6] revision: add Bloom check that includes parent directories
` [PATCH v4 5/6] last-modified: check pathspec against Bloom filter first
` [PATCH v4 6/6] last-modified: keep per-path Bloom filters for wildcard pathspecs
[PATCH v2 0/3] config: read both home and xdg files for --global
2026-09-10 4:48 UTC (4+ messages)
` [PATCH v2 1/3] path: use forward slashes in XDG config on Windows
[PATCH] builtin/whoami: add new 'whoami' command
2026-09-10 3:09 UTC (7+ messages)
` [PATCH v5] var: support broken-down idents, signing key, multiple args, and -z
` [PATCH v6] "
` [PATCH v7] "
[PATCH v2 0/5] Introduce 'uploadpack.lazyFetchTrusted'
2026-09-09 21:39 UTC (6+ messages)
` [PATCH v3 "
` [PATCH v3 4/5] promisor-remote: prevent infinite recursion when lazy fetching
[PATCH 0/4] make: precompile "git-compat-util.h"
2026-09-09 21:07 UTC (7+ messages)
` [PATCH 1/4] Makefile: remove XDIFF_OBJS initialization
` [PATCH 2/4] cmake: remove any "$(*_OBJS)" variables when parsing Makefile for sources
` [PATCH 3/4] Makefile: reintroduce REFTABLE_OBJS
` [PATCH 4/4] Makefile: precompile "git-compat-util.h"
[PATCH 0/3] format-patch: learn --[no-]range-diff-notes
2026-09-09 19:04 UTC (12+ messages)
` [PATCH 3/3] "
Recall: Issue after updating the GIT version from 2.44.0 to 2.50.1
2026-09-09 18:25 UTC
[PATCH 0/2] guides: keep Documentation/Makefile and command-list.txt in sync
2026-09-09 18:15 UTC (5+ messages)
` [PATCH 1/2] command-list: add gitformat-loose(5) and gitpacking(7)
` [PATCH 2/2] lint-docs: check the guide list in command-list.txt
What's cooking in git.git (Sep 2026, #03)
2026-09-09 17:28 UTC (3+ messages)
[PATCH 0/2] push: fix --force-if-includes consulting wrong ref
2026-09-09 11:59 UTC (5+ messages)
` [PATCH v2 "
` [PATCH v2 1/2] push: check pushed ref for --force-if-includes
` [PATCH v2 2/2] push: fix --force-if-includes detached HEAD advice
[PATCH 00/11] Fix inconsistent ref storage format terminology
2026-09-09 11:12 UTC (15+ messages)
` [PATCH v3 00/13] "
` [PATCH v3 01/13] parse-options: allow for hidden aliases
` [PATCH v3 02/13] builtin/init: rename "--ref-format=" to "--ref-storage-format="
` [PATCH v3 03/13] builtin/clone: "
` [PATCH v3 04/13] builtin/refs: "
` [PATCH v3 05/13] builtin/submodule: "
` [PATCH v3 06/13] builtin/rev-parse: rename "--show-ref-format" to "--show-ref-storage-format"
` [PATCH v3 07/13] help: rename "default-ref-format" to "default-ref-storage-format"
` [PATCH v3 08/13] refs: expose function to parse reference URIs
` [PATCH v3 09/13] setup: refactor how we configure the ref storage format
` [PATCH v3 10/13] setup: rename ref storage format environment variables
` [PATCH v3 11/13] t: rename GIT_TEST_DEFAULT_REF_FORMAT
` [PATCH v3 12/13] setup: rename "init.defaultRefFormat" to "init.defaultRefStorageFormat"
` [PATCH v3 13/13] setup: allow "--ref-storage-format=" to specify a payload
[PATCH v2 00/11] Fix inconsistent ref storage format terminology
2026-09-09 9:23 UTC (23+ messages)
` [PATCH v2 01/11] builtin/init: rename "--ref-format=" to "--ref-storage-format="
` [PATCH v2 02/11] builtin/clone: "
` [PATCH v2 03/11] builtin/refs: "
` [PATCH v2 07/11] refs: expose function to parse reference URIs
` [PATCH v2 08/11] setup: refactor how we configure the ref storage format
` [PATCH v2 09/11] setup: rename ref storage format environment variables
` [PATCH v2 11/11] setup: allow "git init --ref-storage-format=" to specify a payload
Participating in Outreachy's December 2026 cohort
2026-09-09 9:12 UTC (3+ messages)
[PATCH v2 00/13] odb: stop registering in-memory sources
2026-09-09 5:52 UTC (8+ messages)
` [PATCH v2 05/13] submodule-config: stop registering submodule sources
` [PATCH v2 10/13] builtin/multi-pack-index: refuse unknown sources with "--object-dir="
[PATCH v3 0/9] odb: write alternates at creation time
2026-09-09 5:48 UTC (10+ messages)
` [PATCH v3 1/9] setup: split up concerns of `init_db()`
` [PATCH v3 2/9] builtin/clone: defer setup of the object database
` [PATCH v3 5/9] builtin/clone: move setup of alternates for shared local clones
[BUG] git bundle create with bitmaps omits tree required by advertised ref
2026-09-08 22:33 UTC (2+ messages)
[PATCH 0/2] rebase: add --fixup to fold a range into its oldest commit
2026-09-08 20:57 UTC (11+ messages)
` [PATCH v15 0/8] history: add squash subcommand to fold a range
` [PATCH v15 1/8] history: extract helper for a commit's parent tree
` [PATCH v15 2/8] history: give commit_tree_ext a message template
` [PATCH v15 3/8] sequencer: share the squash message marker helpers and flags
` [PATCH v15 4/8] history: add skeleton for squash subcommand
` [PATCH v15 5/8] history: validate squash revision ranges
` [PATCH v15 6/8] history: protect branches when squashing a range
` [PATCH v15 7/8] history: create squashed commits without editing
` [PATCH v15 8/8] history: support editing squashed commit messages
[PATCH 0/3] Update t40* tests to use modern style
2026-09-08 20:48 UTC (5+ messages)
` [PATCH 1/3] Update t4001 to use modern syntax
` [PATCH 2/3] Update t4009 to use modern style
` [PATCH 3/3] Update t4010 "
[PATCH v8 0/4] hook: introduce the receive-report hook
2026-09-08 19:50 UTC (3+ messages)
` [PATCH v8 2/4] receive-pack: drop static variables to track report status version
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox