Git development
 help / color / mirror / Atom feed
From: Johannes Schindelin <Johannes.Schindelin@gmx.de>
To: Junio C Hamano <gitster@pobox.com>
Cc: Miklos Vajna <vmiklos@frugalware.org>,
	git@vger.kernel.org, Olivier Marin <dkr@freesurf.fr>
Subject: Re: [PATCH 11/15] Add strbuf_vaddf(), use it in strbuf_addf(), and add strbuf_initf()
Date: Sun, 29 Jun 2008 14:40:57 +0100 (BST)	[thread overview]
Message-ID: <alpine.DEB.1.00.0806291436520.9925@racer> (raw)
In-Reply-To: <7vskuwek9w.fsf@gitster.siamese.dyndns.org>

Hi,

On Sun, 29 Jun 2008, Junio C Hamano wrote:

> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
> 
> > Anyway, I'm fine with having them only in my personal fork.
> 
> It will cost you some "trust point" next time you try to sneak something
> in as a part of a largely unrelated topic.  Please don't.

Fine.  Fine!

I thought it made the code more readable, and that it also might have 
helped other sites where you have to strbuf_init() first, and often need 
curly brackets only because of that.  Making for ultra-ugly code.

Please note that I also added a simple test case for the vaddf() function, 
so your "trying to sneak through" is only half as bad as you made it 
sound.

Also, please note that the situation with SNPRINTF_RETURNS_BOGUS works, 
but is a thorn in this developers eye.

Anyway, I will not try to post this patch again,
Dscho

  reply	other threads:[~2008-06-29 13:44 UTC|newest]

Thread overview: 81+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-06-27 16:21 [PATCH 00/15] Build in merge Miklos Vajna
2008-06-27 16:21 ` [PATCH 01/15] Move split_cmdline() to alias.c Miklos Vajna
2008-06-29 14:05   ` Olivier Marin
2008-06-29 14:15     ` Johannes Schindelin
2008-06-29 14:29       ` Olivier Marin
2008-06-29 14:43         ` Johannes Schindelin
2008-06-30 22:51           ` Olivier Marin
2008-06-27 16:21 ` [PATCH 02/15] Move commit_list_count() to commit.c Miklos Vajna
2008-06-27 16:21 ` [PATCH 03/15] Move parse-options's skip_prefix() to git-compat-util.h Miklos Vajna
2008-06-27 16:21 ` [PATCH 04/15] Add new test to ensure git-merge handles pull.twohead and pull.octopus Miklos Vajna
2008-06-29 13:30   ` Olivier Marin
2008-06-29 14:51     ` [PATCH] " Miklos Vajna
2008-06-29 15:11       ` Miklos Vajna
2008-07-04 16:34   ` [PATCH 04/15] " Mike Ralphson
2008-07-05  0:26     ` Miklos Vajna
2008-07-05  0:32       ` [PATCH] Fix t7601-merge-pull-config.sh on AIX Miklos Vajna
2008-07-05  1:49         ` Junio C Hamano
2008-06-27 16:21 ` [PATCH 05/15] Move read_cache_unmerged() to read-cache.c Miklos Vajna
2008-06-27 16:21 ` [PATCH 06/15] git-fmt-merge-msg: make it usable from other builtins Miklos Vajna
2008-06-27 16:22 ` [PATCH 07/15] Introduce get_octopus_merge_bases() in commit.c Miklos Vajna
2008-06-27 16:22 ` [PATCH 08/15] Add new test to ensure git-merge handles more than 25 refs Miklos Vajna
2008-06-27 17:06   ` Miklos Vajna
2008-06-27 16:22 ` [PATCH 09/15] Introduce get_merge_bases_many() Miklos Vajna
2008-06-27 16:22 ` [PATCH 10/15] Introduce reduce_heads() Miklos Vajna
2008-06-27 16:22 ` [PATCH 11/15] Add strbuf_vaddf(), use it in strbuf_addf(), and add strbuf_initf() Miklos Vajna
2008-06-28  2:00   ` Junio C Hamano
2008-06-28  2:33     ` Miklos Vajna
2008-06-28  2:38       ` [PATCH 13/13] Build in merge Miklos Vajna
2008-06-29  7:46         ` Junio C Hamano
2008-06-29  8:11           ` Jakub Narebski
2008-06-30  1:36           ` Miklos Vajna
2008-06-30  1:39             ` Miklos Vajna
2008-06-30  5:44               ` Junio C Hamano
2008-06-30 17:41                 ` Alex Riesen
2008-07-01  2:13                 ` Miklos Vajna
2008-07-01  2:22                   ` [PATCH 13/14] git-commit-tree: make it usable from other builtins Miklos Vajna
2008-07-01  5:07                     ` Johannes Schindelin
2008-07-01  5:50                     ` Junio C Hamano
2008-07-01 12:09                       ` Miklos Vajna
2008-07-01  2:22                   ` [PATCH 14/14] Build in merge Miklos Vajna
2008-07-01  2:37                     ` [PATCH 00/14] " Miklos Vajna
2008-07-01  2:37                       ` [PATCH 08/14] Add new test to ensure git-merge handles more than 25 refs Miklos Vajna
2008-07-01  2:37                       ` [PATCH 13/14] git-commit-tree: make it usable from other builtins Miklos Vajna
2008-07-01  2:37                       ` [PATCH 14/14] Build in merge Miklos Vajna
2008-07-01  6:23                         ` Junio C Hamano
2008-07-01 12:50                           ` Miklos Vajna
2008-07-01 13:18                             ` Miklos Vajna
2008-07-01 23:55                               ` Junio C Hamano
2008-07-02  7:43                                 ` Miklos Vajna
2008-07-06  8:50                               ` Junio C Hamano
2008-07-06  9:43                                 ` Junio C Hamano
2008-07-07 17:17                                   ` Miklos Vajna
2008-07-07 18:15                                     ` Junio C Hamano
2008-07-07 23:42                                       ` [PATCH] " Miklos Vajna
2008-07-08  0:32                                         ` Junio C Hamano
2008-07-08  0:53                                           ` Junio C Hamano
2008-07-08  1:18                                             ` Miklos Vajna
2008-07-08  1:00                                           ` Miklos Vajna
2008-07-08  1:05                                             ` Junio C Hamano
2008-07-08  1:41                                               ` Miklos Vajna
2008-07-06 12:38                                 ` [PATCH 14/14] " Johannes Schindelin
2008-07-06 19:39                                   ` Junio C Hamano
2008-07-07 17:24                                 ` [PATCH] " Miklos Vajna
2008-07-07 17:35                                   ` Miklos Vajna
2008-07-01  7:27                         ` [PATCH 14/14] " Junio C Hamano
2008-07-01 12:55                           ` Miklos Vajna
2008-06-30 22:44               ` [PATCH 13/13] " Olivier Marin
2008-06-30 22:58                 ` Miklos Vajna
2008-06-30  5:40             ` Junio C Hamano
2008-06-30 22:48               ` Miklos Vajna
2008-06-28 17:33     ` [PATCH 11/15] Add strbuf_vaddf(), use it in strbuf_addf(), and add strbuf_initf() Johannes Schindelin
2008-06-29  8:07       ` Junio C Hamano
2008-06-29 13:40         ` Johannes Schindelin [this message]
2008-06-29 20:17           ` Alex Riesen
2008-06-29 20:24             ` Junio C Hamano
2008-06-29 20:30               ` Sverre Rabbelier
2008-06-27 16:22 ` [PATCH 12/15] strbuf_vaddf(): support %*s, too Miklos Vajna
2008-06-27 16:22 ` [PATCH 13/15] Add new test case to ensure git-merge reduces octopus parents when possible Miklos Vajna
2008-06-27 16:22 ` [PATCH 14/15] Add new test case to ensure git-merge prepends the custom merge message Miklos Vajna
2008-06-27 16:22 ` [PATCH 15/15] Build in merge Miklos Vajna
2008-06-27 17:09   ` Miklos Vajna

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.1.00.0806291436520.9925@racer \
    --to=johannes.schindelin@gmx.de \
    --cc=dkr@freesurf.fr \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    --cc=vmiklos@frugalware.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox