Git development
 help / color / mirror / Atom feed
From: Johannes Schindelin <Johannes.Schindelin@gmx.de>
To: Junio C Hamano <gitster@pobox.com>
Cc: git@vger.kernel.org
Subject: Re: [PATCH for master] Rename path_list to string_list
Date: Tue, 22 Jul 2008 13:09:47 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.1.00.0807221308050.3391@eeepc-johanness> (raw)
In-Reply-To: <7v3am2sldy.fsf@gitster.siamese.dyndns.org>

Hi,

On Mon, 21 Jul 2008, Junio C Hamano wrote:

> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
> 
> > @@ -64,9 +65,10 @@ Functions
> >  
> >  `string_list_clear`::
> >  
> > -	Free a string_list. The `path` pointer of the items will be freed in case
> > -	the `strdup_strings` member of the string_list is set. The second parameter
> > -	controls if the `util` pointer of the items should be freed or not.
> > +	Free a string_list. The `path` pointer of the items will be freed in
> > +	case the `strdup_strings` member of the string_list is set. The second
> > +	parameter controls if the `util` pointer of the items should be freed
> > +	or not.
> 
> Missed 's/path/string/' here?

Good catch.  I clearly forgot to grep for "path" in all the files that I 
touched.  I did that now, but only looked at comments (in the hope that 
the compiler would have caught the other ones).

-- snipsnap --
[PATCH] Fix two leftovers from path_list->string_list

In the documentation, where you cannot get compile errors for using the
wrong member name, there were two mentions of 'path' left.

Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
---
 Documentation/technical/api-string-list.txt |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/technical/api-string-list.txt b/Documentation/technical/api-string-list.txt
index 92b3ecd..293bb15 100644
--- a/Documentation/technical/api-string-list.txt
+++ b/Documentation/technical/api-string-list.txt
@@ -41,7 +41,7 @@ memset(&list, 0, sizeof(struct string_list));
 string_list_append("foo", &list);
 string_list_append("bar", &list);
 for (i = 0; i < list.nr; i++)
-	printf("%s\n", list.items[i].path)
+	printf("%s\n", list.items[i].string)
 ----
 
 NOTE: It is more efficient to build an unsorted list and sort it
@@ -113,7 +113,7 @@ Data structures
 
 * `struct string_list_item`
 
-Represents an item of the list. The `path` member is a pointer to the
+Represents an item of the list. The `string` member is a pointer to the
 string, and you may use the `util` member for any purpose, if you want.
 
 * `struct string_list`
-- 
1.5.6.2.516.g22071

      reply	other threads:[~2008-07-22 11:10 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-07-21 18:03 [PATCH for master] Rename path_list to string_list Johannes Schindelin
2008-07-21 18:05 ` Johannes Schindelin
2008-07-21 23:33   ` Johannes Schindelin
2008-07-22  2:28   ` Junio C Hamano
2008-07-22 11:09     ` Johannes Schindelin [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.1.00.0807221308050.3391@eeepc-johanness \
    --to=johannes.schindelin@gmx.de \
    --cc=git@vger.kernel.org \
    --cc=gitster@pobox.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox