From: Justin Tobler <jltobler@gmail.com>
To: Patrick Steinhardt <ps@pks.im>
Cc: git@vger.kernel.org
Subject: Re: [PATCH 6/7] odb/streaming: rename `struct read_object_fd_data`
Date: Tue, 4 Aug 2026 13:25:21 -0500 [thread overview]
Message-ID: <anIuT6GFJ8st-cF4@denethor> (raw)
In-Reply-To: <20260804-pks-odb-stream-unification-v1-6-86d70e82345e@pks.im>
On 26/08/04 09:25AM, Patrick Steinhardt wrote:
> With the preceding refactorings the `struct read_object_fd_data` is now
> somewhat misnamed, as it doesn't only contain the data anymore, but also
> the stream itself. Rename the structure to `struct fd_stream` to better
> match the new structure.
Ah ok, this addresses one of my comments in the last patch. The renames
here all look good.
-Justin
next prev parent reply other threads:[~2026-08-04 18:25 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-04 7:25 [PATCH 0/7] odb: unify read and write streams Patrick Steinhardt
2026-08-04 7:25 ` [PATCH 1/7] odb/streaming: track write stream size in the structure Patrick Steinhardt
2026-08-04 16:47 ` Justin Tobler
2026-08-04 7:25 ` [PATCH 2/7] odb/streaming: drop `is_finished` field Patrick Steinhardt
2026-08-04 17:46 ` Justin Tobler
2026-08-04 7:25 ` [PATCH 3/7] odb/streaming: support streaming arbitrary object types Patrick Steinhardt
2026-08-04 18:03 ` Justin Tobler
2026-08-05 6:06 ` Patrick Steinhardt
2026-08-04 18:54 ` Junio C Hamano
2026-08-05 6:06 ` Patrick Steinhardt
2026-08-04 7:25 ` [PATCH 4/7] odb/streaming: rename `struct odb_read_stream` Patrick Steinhardt
2026-08-04 7:25 ` [PATCH 5/7] odb/streaming: consolidate read and write streams Patrick Steinhardt
2026-08-04 18:23 ` Justin Tobler
2026-08-05 6:06 ` Patrick Steinhardt
2026-08-04 7:25 ` [PATCH 6/7] odb/streaming: rename `struct read_object_fd_data` Patrick Steinhardt
2026-08-04 18:25 ` Justin Tobler [this message]
2026-08-04 7:25 ` [PATCH 7/7] odb/streaming: unify function names to create new streams Patrick Steinhardt
2026-08-04 18:30 ` Justin Tobler
2026-08-05 7:44 ` [PATCH v2 0/8] odb: unify read and write streams Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 1/8] odb/streaming: track write stream size in the structure Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 2/8] odb/streaming: drop `is_finished` field Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 3/8] odb/streaming: support streaming arbitrary object types Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 4/8] odb/streaming: rename `struct odb_read_stream` Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 5/8] odb/streaming: consolidate read and write streams Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 6/8] odb/streaming: rename `struct read_object_fd_data` Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 7/8] odb/streaming: rename `struct input_zstream_data` Patrick Steinhardt
2026-08-05 7:44 ` [PATCH v2 8/8] odb/streaming: unify function names to create new streams Patrick Steinhardt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anIuT6GFJ8st-cF4@denethor \
--to=jltobler@gmail.com \
--cc=git@vger.kernel.org \
--cc=ps@pks.im \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox