From: Patrick Steinhardt <ps@pks.im>
To: Derrick Stolee <stolee@gmail.com>
Cc: git@vger.kernel.org, Thomas Bachem <mail@thomasbachem.com>,
Phillip Wood <phillip.wood@dunelm.org.uk>
Subject: Re: [PATCH 2/2] builtin/maintenance: improve heuristic for "rerere gc"
Date: Fri, 4 Sep 2026 07:21:25 +0200 [thread overview]
Message-ID: <appVVYr6oW0fyMRD@pks.im> (raw)
In-Reply-To: <2ca2b4db-1fd9-46e8-9385-260a12af43bb@gmail.com>
On Thu, Sep 03, 2026 at 10:19:33AM -0400, Derrick Stolee wrote:
> On 9/3/2026 5:04 AM, Patrick Steinhardt wrote:
> > diff --git a/builtin/gc.c b/builtin/gc.c
> > index de2f9e7fed..9147418a61 100644
> > --- a/builtin/gc.c
> > +++ b/builtin/gc.c
> > @@ -396,31 +396,13 @@ static int maintenance_task_rerere_gc(struct maintenance_run_opts *opts UNUSED,
> >
> > static int rerere_gc_condition(struct gc_config *cfg UNUSED)
> > {
> > - struct strbuf path = STRBUF_INIT;
> > - int should_gc = 0, limit = 1;
> > - DIR *dir = NULL;
> > + int limit = 512;
> >
> > repo_config_get_int(the_repository, "maintenance.rerere-gc.auto", &limit);
> > + if (limit <= 0)
> > + return limit < 0;
>
> This is cute, but works. It's logically equivalent to
>
> if (!limit)
> return 0;
> if (limit < 0)
> return 1;
>
> which would map more directly to the two documented cases. It takes
> the slightest amount of mental processing to connect the docs to
> the format you have.
This also existed in the preimage, but I agree it's harder to read than
really necessary. Will improve while at it.
> > + return rerere_gc_estimate(the_repository, limit) >= (size_t)limit;
> > }
>
> I do like that this method is simpler in the builtin code in favor
> of a method that has access to rerere internals.
>
> I do wonder if rerere_gc_estimate() should be
> rerere_stale_above_limit() instead, as we are not using any callers
> that care about the resulting number other than "is it at least limit?"
Agreed, the current name isn't great. I'm somehow hestitant to use
`rerere_stale_above_limit()` too, though. I'll adapt it to
`rerere_gc_needed()` instead.
Thanks for your review!
Patrick
next prev parent reply other threads:[~2026-09-04 5:21 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-03 9:04 [PATCH 0/2] builtin/maintenance: improve heuristic for "rerere gc" Patrick Steinhardt
2026-09-03 9:04 ` [PATCH 1/2] rerere: extract logic to determine whether entries are stale Patrick Steinhardt
2026-09-03 14:11 ` Derrick Stolee
2026-09-04 5:21 ` Patrick Steinhardt
2026-09-03 9:04 ` [PATCH 2/2] builtin/maintenance: improve heuristic for "rerere gc" Patrick Steinhardt
2026-09-03 14:19 ` Derrick Stolee
2026-09-04 5:21 ` Patrick Steinhardt [this message]
2026-09-03 12:12 ` [PATCH 0/2] " Thomas Bachem
2026-09-04 7:03 ` [PATCH v2 " Patrick Steinhardt
2026-09-04 7:03 ` [PATCH v2 1/2] rerere: extract logic to determine whether entries are stale Patrick Steinhardt
2026-09-04 7:03 ` [PATCH v2 2/2] builtin/maintenance: improve heuristic for "rerere gc" Patrick Steinhardt
2026-09-04 13:51 ` [PATCH v2 0/2] " Derrick Stolee
2026-09-04 14:48 ` Junio C Hamano
2026-09-04 16:14 ` Junio C Hamano
2026-09-04 16:53 ` Thomas Bachem
2026-09-07 6:15 ` Patrick Steinhardt
2026-09-07 6:15 ` Patrick Steinhardt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=appVVYr6oW0fyMRD@pks.im \
--to=ps@pks.im \
--cc=git@vger.kernel.org \
--cc=mail@thomasbachem.com \
--cc=phillip.wood@dunelm.org.uk \
--cc=stolee@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox