Git development
 help / color / mirror / Atom feed
From: Junio C Hamano <gitster@pobox.com>
To: Jeff King <peff@peff.net>
Cc: Stephan Beyer <s-beyer@gmx.net>, Ariel <asgit@dsgml.com>,
	git@vger.kernel.org
Subject: Re: git add -p with new file
Date: Tue, 13 Dec 2016 10:48:07 -0800	[thread overview]
Message-ID: <xmqq7f734qe0.fsf@gitster.mtv.corp.google.com> (raw)
In-Reply-To: <20161213173341.wemlunlixdp6277h@sigill.intra.peff.net> (Jeff King's message of "Tue, 13 Dec 2016 12:33:41 -0500")

Jeff King <peff@peff.net> writes:

>> I am also not really sure what problem this feature is trying to solve.
>> If the "problem"(?) is that it should act more like "git add" instead of
>> "git add -u", for whatever reason, this may be fine (but the
>> configuration option is a must-have then).
>
> I think the problem is just that "add -p" does not give the whole story
> of what you might want to do before making a commit.

The same is shared by "git diff [HEAD]", by the way.  It is beyond
me why people use "add -p", not "git diff [HEAD]", for the final
sanity check before committing.  

Perhaps the latter is not advertised well enough?  "add -p" does not
even page so it is not very useful way to check what is being added
if you are adding a new file (unless you are doing a toy example to
add a 7-line file).

>> > I'd also probably add interactive.showUntracked to make the whole thing
>> > optional (but I think it would be OK to default it to on).
>> Hm, "interactive.showUntracked" is a confusing name because "git add -i"
>> (interactive) already handles untracked files.
>
> Sure, that was just meant for illustration. I agree there's probably a
> better name.

"interactive.*" is not a sensible hierarchy to use, because things
other than "add" can go interactive.

addPatch.showUntracked?

  reply	other threads:[~2016-12-13 18:48 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-12-07  1:18 git add -p with new file Ariel
2016-12-07  9:22 ` Duy Nguyen
2016-12-09 18:26   ` Ariel
2016-12-12 20:24     ` Stephan Beyer
2016-12-09 14:11 ` Jeff King
2016-12-09 18:43   ` Ariel
2016-12-10  8:55     ` Jeff King
2016-12-10 22:04       ` Junio C Hamano
2016-12-11 13:00         ` Jeff King
2016-12-12 20:31           ` Stephan Beyer
2016-12-13 17:33             ` Jeff King
2016-12-13 18:48               ` Junio C Hamano [this message]
2016-12-13 18:56                 ` Jeff King
2016-12-13 19:12                   ` Junio C Hamano
2016-12-13 19:21 ` git add -p with unmerged files (was: git add -p with new file) Stephan Beyer
2016-12-13 19:49   ` Jeff King
2016-12-13 19:59   ` git add -p with unmerged files Junio C Hamano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=xmqq7f734qe0.fsf@gitster.mtv.corp.google.com \
    --to=gitster@pobox.com \
    --cc=asgit@dsgml.com \
    --cc=git@vger.kernel.org \
    --cc=peff@peff.net \
    --cc=s-beyer@gmx.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox