From: Junio C Hamano <gitster@pobox.com>
To: "D. Ben Knoble" <ben.knoble@gmail.com>
Cc: Yoichi NAKAYAMA via GitGitGadget <gitgitgadget@gmail.com>,
git@vger.kernel.org, Harald Nordgren <haraldnordgren@gmail.com>,
Yoichi Nakayama <yoichi.nakayama@gmail.com>
Subject: Re: [PATCH v5 1/2] checkout: improve message for ambiguous remote branch name
Date: Wed, 19 Aug 2026 19:18:16 -0700 [thread overview]
Message-ID: <xmqqjyplttzr.fsf@gitster.g> (raw)
In-Reply-To: <CALnO6CCQppTnw1Y-6ibmcko0dM3hy8riPanD9BNyb+MW8a5nAw@mail.gmail.com> (D. Ben Knoble's message of "Wed, 19 Aug 2026 18:54:02 -0400")
"D. Ben Knoble" <ben.knoble@gmail.com> writes:
>> +static void be_explicit(const char *branch,
>
> Be explicit about what? Reading below, a better name might be
> "advise_ambiguous_remote_branch_name" or something, idk.
It stands for "tell the user to be more explicit". I agree with you
that the refactoring should be done as a separate step, on top of
which we should add the new feature, i.e., "give list of possible
candidates", as a separate step.
next prev parent reply other threads:[~2026-08-20 2:18 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-08 8:21 [PATCH] worktree add: improve message for ambiguous remote branch name Yoichi NAKAYAMA via GitGitGadget
2026-08-08 17:00 ` Junio C Hamano
2026-08-08 21:57 ` Junio C Hamano
2026-08-09 7:45 ` Harald Nordgren
2026-08-09 18:19 ` Junio C Hamano
2026-08-10 10:12 ` Harald Nordgren
2026-08-09 18:17 ` Junio C Hamano
2026-08-10 13:04 ` Yoichi Nakayama
2026-08-10 13:00 ` Yoichi Nakayama
2026-08-10 13:07 ` D. Ben Knoble
2026-08-10 13:35 ` Yoichi Nakayama
2026-08-10 15:06 ` Junio C Hamano
2026-08-10 21:36 ` Yoichi Nakayama
2026-08-11 16:38 ` Ben Knoble
2026-08-12 13:14 ` Yoichi Nakayama
2026-08-10 15:07 ` [PATCH v2] " Yoichi NAKAYAMA via GitGitGadget
2026-08-10 20:55 ` [PATCH v3] " Yoichi NAKAYAMA via GitGitGadget
2026-08-11 0:03 ` Junio C Hamano
2026-08-11 6:31 ` Yoichi Nakayama
2026-08-12 19:22 ` Junio C Hamano
2026-08-15 4:36 ` Yoichi Nakayama
2026-08-11 6:35 ` [PATCH v4] " Yoichi NAKAYAMA via GitGitGadget
2026-08-19 12:50 ` [PATCH v5 0/2] " Yoichi NAKAYAMA via GitGitGadget
2026-08-19 12:50 ` [PATCH v5 1/2] checkout: " Yoichi NAKAYAMA via GitGitGadget
2026-08-19 22:54 ` D. Ben Knoble
2026-08-20 2:18 ` Junio C Hamano [this message]
2026-08-19 12:50 ` [PATCH v5 2/2] worktree add: " Yoichi NAKAYAMA via GitGitGadget
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=xmqqjyplttzr.fsf@gitster.g \
--to=gitster@pobox.com \
--cc=ben.knoble@gmail.com \
--cc=git@vger.kernel.org \
--cc=gitgitgadget@gmail.com \
--cc=haraldnordgren@gmail.com \
--cc=yoichi.nakayama@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox