From: sashiko-bot@kernel.org
To: Frank.Li@oss.nxp.com
Cc: robh@kernel.org, Frank.Li@kernel.org, imx@lists.linux.dev,
conor+dt@kernel.org, devicetree@vger.kernel.org
Subject: Re: [PATCH 1/5] ARM: dts: ls1021a-moxa-uc-8410a: add led suffix to fix CHECK_DTBS warnings
Date: Wed, 08 Jul 2026 19:33:14 +0000 [thread overview]
Message-ID: <20260708193315.9B8821F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260708-ls-dts-warning-v1-1-5daa24061c31@nxp.com>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] Appending the '-led' suffix to non-LED hardware components artificially bypasses DT schema validation while falsely describing the hardware.
--
--- Patch [1]: [PATCH 1/5] ARM: dts: ls1021a-moxa-uc-8410a: add led suffix to fix CHECK_DTBS warnings ---
commit 74fab37b2f25e9ccf8e82f5b1103b80dbcd12253
Author: Frank Li <Frank.Li@nxp.com>
ARM: dts: ls1021a-moxa-uc-8410a: add led suffix to fix CHECK_DTBS warnings
This commit appends the -led suffix to several nodes within a gpio-leds
block to resolve dtbs_check warnings.
> diff --git a/arch/arm/boot/dts/nxp/ls/ls1021a-moxa-uc-8410a.dts b/arch/arm/boot/dts/nxp/ls/ls1021a-moxa-uc-8410a.dts
> index d2cae8c7d7a61..8efe6b615ca85 100644
> --- a/arch/arm/boot/dts/nxp/ls/ls1021a-moxa-uc-8410a.dts
> +++ b/arch/arm/boot/dts/nxp/ls/ls1021a-moxa-uc-8410a.dts
> @@ -40,13 +40,13 @@ reg_3p3v: regulator-3p3v {
> leds {
> compatible = "gpio-leds";
>
> - cel-pwr {
> + cel-pwr-led {
> label = "UC8410A:CEL-PWR";
> gpios = <&gpio3 27 GPIO_ACTIVE_LOW>;
> default-state = "off";
> };
>
> - cel-reset {
> + cel-reset-led {
> label = "UC8410A:CEL-RESET";
> gpios = <&gpio3 28 GPIO_ACTIVE_LOW>;
> default-state = "off";
> };
[Severity: Low]
Does appending the -led suffix here artificially bypass DT schema validation
while falsely describing the hardware?
Placing these cellular modem control lines under the gpio-leds compatible
node was existing behavior, but renaming them to include -led simply hides
the validation warning from the linter instead of migrating the pins to an
appropriate modem or power controller abstraction.
> @@ -58,13 +58,13 @@ str-led {
> linux,default-trigger = "mmc0";
> };
>
> - sw-ready {
> + sw-ready-led {
> label = "UC8410A:GREEN:SWRDY";
> gpios = <&gpio0 18 GPIO_ACTIVE_HIGH>;
> default-state = "on";
> };
>
> - beeper {
> + beeper-led {
> label = "UC8410A:BEEP";
> gpios = <&gpio0 20 GPIO_ACTIVE_HIGH>;
> default-state = "off";
> };
[Severity: Low]
Is it correct to label an acoustic device as an LED?
Similar to the cellular GPIOs above, using gpio-leds for a beeper is an
existing inaccuracy, but renaming it to beeper-led strictly to satisfy
the regex solidifies an incorrect hardware description. Would it be better
to migrate this to use gpio-beeper instead?
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260708-ls-dts-warning-v1-0-5daa24061c31@nxp.com?part=1
next prev parent reply other threads:[~2026-07-08 19:33 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-08 19:26 [PATCH 0/5] ARM: dts: ls1021a: dts CHECK_DTBS warning cleanup Frank.Li
2026-07-08 19:26 ` [PATCH 1/5] ARM: dts: ls1021a-moxa-uc-8410a: add led suffix to fix CHECK_DTBS warnings Frank.Li
2026-07-08 19:33 ` sashiko-bot [this message]
2026-07-08 19:26 ` [PATCH 2/5] ARM: dts: ls1021a-twr: add power-supply for lcd panel Frank.Li
2026-07-08 19:26 ` [PATCH 3/5] ARM: dts: ls1021a-moxa-uc-8410a: use compatible string ethernet-phy-ieee802.3-c22 Frank.Li
2026-07-08 19:26 ` [PATCH 4/5] ARM: dts: ls1021a-moxa-uc-8410a: replace spansion,s25fl164k with jedec,spi-nor Frank.Li
2026-07-08 19:26 ` [PATCH 5/5] ARM: dts: ls1021a-moxa-uc-8410a: remove undocument property default-state of gpio-keys Frank.Li
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260708193315.9B8821F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=Frank.Li@kernel.org \
--cc=Frank.Li@oss.nxp.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=imx@lists.linux.dev \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox