From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Frank.Li@oss.nxp.com
Cc: "Jacky Huang" <ychuang3@nuvoton.com>,
"Shan-Chun Hung" <schung@nuvoton.com>,
"Vinod Koul" <vkoul@kernel.org>, "Frank Li" <Frank.Li@kernel.org>,
"Paul Cercueil" <paul@crapouillou.net>,
"Eugeniy Paltsev" <Eugeniy.Paltsev@synopsys.com>,
"Binbin Zhou" <zhoubinbin@loongson.cn>,
"Patrice Chotard" <patrice.chotard@foss.st.com>,
"Amélie Delaunay" <amelie.delaunay@foss.st.com>,
"Maxime Coquelin" <mcoquelin.stm32@gmail.com>,
"Alexandre Torgue" <alexandre.torgue@foss.st.com>,
"Steven Rostedt" <rostedt@goodmis.org>,
"Masami Hiramatsu" <mhiramat@kernel.org>,
"Mathieu Desnoyers" <mathieu.desnoyers@efficios.com>,
"Thierry Reding" <thierry.reding@kernel.org>,
"Jonathan Hunter" <jonathanh@nvidia.com>,
"Ludovic Desroches" <ludovic.desroches@microchip.com>,
"Viresh Kumar" <vireshk@kernel.org>,
"Keguang Zhang" <keguang.zhang@gmail.com>,
"Andreas Färber" <afaerber@suse.de>,
"Manivannan Sadhasivam" <mani@kernel.org>,
"Daniel Mack" <daniel@zonque.org>,
"Haojian Zhuang" <haojian.zhuang@gmail.com>,
"Robert Jarzmik" <robert.jarzmik@free.fr>,
"Chen-Yu Tsai" <wens@kernel.org>,
"Jernej Skrabec" <jernej.skrabec@gmail.com>,
"Samuel Holland" <samuel@sholland.org>,
"Kelvin Cao" <kelvin.cao@microchip.com>,
"Logan Gunthorpe" <logang@deltatee.com>,
"Laxman Dewangan" <ldewangan@nvidia.com>,
"Vignesh Raghavendra" <vigneshr@ti.com>,
linux-arm-kernel@lists.infradead.org, dmaengine@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-mips@vger.kernel.org,
linux-stm32@st-md-mailman.stormreply.com,
linux-trace-kernel@vger.kernel.org, linux-tegra@vger.kernel.org,
linux-actions@lists.infradead.org, linux-sunxi@lists.linux.dev,
imx@lists.linux.dev, "Frank Li" <Frank.Li@nxp.com>
Subject: Re: [PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
Date: Sat, 5 Sep 2026 10:59:35 +0300 [thread overview]
Message-ID: <apvL5yXKGHrEyp9Z@ashevche-desk.local> (raw)
In-Reply-To: <20260904-dma-chan_dev-rename-v3-4-685601b0b788@nxp.com>
On Fri, Sep 04, 2026 at 05:49:46PM -0400, Frank.Li@oss.nxp.com wrote:
> The current dma_chan structure contains both "device" and "dev". So
>
> chan->device->dev refers to the DMA engine device.
> chan->dev->device refers to the per-channel device instance.
>
> Their similar naming makes the distinction unclear and increases reader
> confusion.
>
> Add union dma_chan::chan_dev to make its purpose explicit and clearly
> identify it as the per-channel device. After all user switch to chan_dev,
> union and dma_chan::dev will be removed.
>
> Update the kernel-doc accordingly. Besides its sysfs usage, the per-channel
> device is also used by some DMA engine drivers for IOMMU mapping and
> therefore deserves a more accurate description.
>
> No functional change intended.
I was almost ready to give a tag for the entire series, but found a minor
issue here...
...
> +++ b/include/linux/dmaengine.h
> struct dma_router {
> * @lock: protect between config and prepare transfer when driver have not
> * implemented callback device_prep_config_sg().
> * @chan_id: channel ID for sysfs
> - * @dev: class device for sysfs
> + * @chan_dev: class channel device for sysfs, some device use it for per-channel
> + * iommu mapping.
IOMMU
> * @name: backlink name for sysfs
> * @dbg_client_name: slave name for debugfs in format:
> * dev_name(requester's dev):channel name, for example: "2b00000.mcasp:tx"
> struct dma_chan {
>
> /* sysfs */
> int chan_id;
> - struct dma_chan_dev *dev;
> + union {
> + struct dma_chan_dev *chan_dev;
> + /*
> + * please use chan_dev, dev will be removed after all user
> + switch to chan_dev
> + */
Something went wrong with this comment style. It also need to respect English
grammar and punctuation as we do for multi-line comments.
> + struct dma_chan_dev *dev;
> + };
> const char *name;
> #ifdef CONFIG_DEBUG_FS
> char *dbg_client_name;
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2026-09-05 7:59 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-04 21:49 [PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity Frank.Li
2026-09-04 21:49 ` [PATCH v3 1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name Frank.Li
2026-09-04 22:04 ` sashiko-bot
2026-09-04 21:49 ` [PATCH v3 2/4] dmaengine: use dma_chan_name() helper to get per-channel " Frank.Li
2026-09-04 21:58 ` sashiko-bot
2026-09-05 7:55 ` Andy Shevchenko
2026-09-04 21:49 ` [PATCH v3 3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper Frank.Li
2026-09-04 22:02 ` sashiko-bot
2026-09-04 21:49 ` [PATCH v3 4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity Frank.Li
2026-09-04 22:01 ` sashiko-bot
2026-09-05 7:59 ` Andy Shevchenko [this message]
2026-09-05 8:00 ` [PATCH v3 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev " Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=apvL5yXKGHrEyp9Z@ashevche-desk.local \
--to=andriy.shevchenko@linux.intel.com \
--cc=Eugeniy.Paltsev@synopsys.com \
--cc=Frank.Li@kernel.org \
--cc=Frank.Li@nxp.com \
--cc=Frank.Li@oss.nxp.com \
--cc=afaerber@suse.de \
--cc=alexandre.torgue@foss.st.com \
--cc=amelie.delaunay@foss.st.com \
--cc=daniel@zonque.org \
--cc=dmaengine@vger.kernel.org \
--cc=haojian.zhuang@gmail.com \
--cc=imx@lists.linux.dev \
--cc=jernej.skrabec@gmail.com \
--cc=jonathanh@nvidia.com \
--cc=keguang.zhang@gmail.com \
--cc=kelvin.cao@microchip.com \
--cc=ldewangan@nvidia.com \
--cc=linux-actions@lists.infradead.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mips@vger.kernel.org \
--cc=linux-stm32@st-md-mailman.stormreply.com \
--cc=linux-sunxi@lists.linux.dev \
--cc=linux-tegra@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=logang@deltatee.com \
--cc=ludovic.desroches@microchip.com \
--cc=mani@kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mcoquelin.stm32@gmail.com \
--cc=mhiramat@kernel.org \
--cc=patrice.chotard@foss.st.com \
--cc=paul@crapouillou.net \
--cc=robert.jarzmik@free.fr \
--cc=rostedt@goodmis.org \
--cc=samuel@sholland.org \
--cc=schung@nuvoton.com \
--cc=thierry.reding@kernel.org \
--cc=vigneshr@ti.com \
--cc=vireshk@kernel.org \
--cc=vkoul@kernel.org \
--cc=wens@kernel.org \
--cc=ychuang3@nuvoton.com \
--cc=zhoubinbin@loongson.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox