From mboxrd@z Thu Jan 1 00:00:00 1970 From: Chris Wilson Subject: Re: [RFC] drm/i915: opencode get/put irq for gen6+ Date: Thu, 29 Mar 2012 21:32:50 +0100 Message-ID: <1333053184_146777@CP5-2952> References: <1333049209-1978-1-git-send-email-ben@bwidawsk.net> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from fireflyinternet.com (smtp.fireflyinternet.com [109.228.6.236]) by gabe.freedesktop.org (Postfix) with ESMTP id 7F86A9E752 for ; Thu, 29 Mar 2012 13:33:16 -0700 (PDT) In-Reply-To: <1333049209-1978-1-git-send-email-ben@bwidawsk.net> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: intel-gfx@lists.freedesktop.org Cc: Ben Widawsky , Ben Widawsky List-Id: intel-gfx@lists.freedesktop.org On Thu, 29 Mar 2012 12:26:49 -0700, Ben Widawsky wrote: > Before Chris get's all mad and complains that I did the opposite with > semaphores - semaphores did have a bit of logic which many had found > confusing and it was greatly simplified by abstracting it. > > Anyhow, this removes a few lines that really didn't serve much purpose. Yup, looks a worthwhile saving. > It also seems I can collapse the GT and GEN6 interrupt definitions into > 1, but I'll have to check, and it's a separate patch anyway. But that's the patch I've been waiting for too long now! And I think this patch would look even better afterwards. -Chris -- Chris Wilson, Intel Open Source Technology Centre