From mboxrd@z Thu Jan 1 00:00:00 1970 From: Imre Deak Subject: [PATCH v3 0/4] prepare for multiple power wells Date: Fri, 25 Oct 2013 17:36:46 +0300 Message-ID: <1382711810-25881-1-git-send-email-imre.deak@intel.com> References: <1382464076-5030-1-git-send-email-imre.deak@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mga09.intel.com (mga09.intel.com [134.134.136.24]) by gabe.freedesktop.org (Postfix) with ESMTP id 20C64E6A4C for ; Fri, 25 Oct 2013 07:36:56 -0700 (PDT) In-Reply-To: <1382464076-5030-1-git-send-email-imre.deak@intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org This patchset replaces "[PATCH 6/6] drm/i915: use power get/put instead of set for power on after init" from my previous patchset. I addressed the feedback from Daniel and Paulo (patch 1-3) and included a related cleanup (patch 4). Imre Deak (4): drm/i915: prepare for multiple power wells drm/i915: use power get/put instead of set for power on after init drm/i915: remove device field from struct power_well drm/i915: rename i915_init_power_well to i915_init_power_domains drivers/gpu/drm/i915/i915_dma.c | 10 ++-- drivers/gpu/drm/i915/i915_drv.c | 4 +- drivers/gpu/drm/i915/i915_drv.h | 20 +++++-- drivers/gpu/drm/i915/intel_display.c | 17 ++++++ drivers/gpu/drm/i915/intel_drv.h | 7 ++- drivers/gpu/drm/i915/intel_pm.c | 109 ++++++++++++++++------------------- 6 files changed, 92 insertions(+), 75 deletions(-) -- 1.8.4