From mboxrd@z Thu Jan 1 00:00:00 1970 From: Imre Deak Subject: [PATCH 0/8] support for multiple power wells Date: Fri, 1 Nov 2013 19:19:46 +0200 Message-ID: <1383326394-3933-1-git-send-email-imre.deak@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mga03.intel.com (mga03.intel.com [143.182.124.21]) by gabe.freedesktop.org (Postfix) with ESMTP id 4F2E1F0701 for ; Fri, 1 Nov 2013 10:20:23 -0700 (PDT) List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces@lists.freedesktop.org Errors-To: intel-gfx-bounces@lists.freedesktop.org To: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org This patchset adds support for multiple dynamic power wells needed by future platforms. Besides adding a debugfs entry for power domain info it doesn't have any functional change. I also included a related patch from Jesse that isn't applied yet, but is a dependency for this patchset. I did some smoke test on SNB/HSW/VLV. Imre Deak (7): drm/i915: add audio power domain drm/i915: support for multiple power wells drm/i915: add always-on power wells instead of special casing them drm/i915: s/HAS_POWER_WELL/IS_HASWELL/ in intel_display_capture_error_state drm/i915: restrict HSW specific powerdomains HW init to HSW drm/i915: add a default always-on power well drm/i915: add a debugfs entry for power domain info Jesse Barnes (1): drm/i915: protect HSW power well check with IS_HASWELL in redisable_vga drivers/gpu/drm/i915/i915_debugfs.c | 68 +++++++++++++++ drivers/gpu/drm/i915/i915_dma.c | 18 ++-- drivers/gpu/drm/i915/i915_drv.h | 15 +++- drivers/gpu/drm/i915/intel_display.c | 6 +- drivers/gpu/drm/i915/intel_pm.c | 165 +++++++++++++++++++++-------------- 5 files changed, 190 insertions(+), 82 deletions(-) -- 1.8.4