From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jesse Barnes Subject: Re: [Intel-gfx] [PATCH 1/5] drm/i915: Use dp_detect_common in hotplug helper function Date: Tue, 26 Jul 2011 09:36:24 -0700 Message-ID: <20110726093624.2d067e1b@jbarnes-desktop> References: <1311662194-4050-1-git-send-email-keithp@keithp.com> <1311662194-4050-2-git-send-email-keithp@keithp.com> Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <1311662194-4050-2-git-send-email-keithp@keithp.com> Sender: linux-kernel-owner@vger.kernel.org To: Keith Packard Cc: Dave Airlie , intel-gfx@lists.freedesktop.org, linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Mon, 25 Jul 2011 23:36:30 -0700 Keith Packard wrote: > This uses the common dpcd reading routine, i915_dp_detect_common, > instead of open-coding a call to intel_dp_aux_native_read. Besides > reducing duplicated code, this also gains the read retries which > may be necessary when a cable is first plugged back in and the link > needs to be retrained. > > Signed-off-by: Keith Packard > --- > drivers/gpu/drm/i915/intel_dp.c | 39 +++++++++++++++++++-------------------- > 1 files changed, 19 insertions(+), 20 deletions(-) > > diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c > index dcc7ae6..45db810 100644 > --- a/drivers/gpu/drm/i915/intel_dp.c > +++ b/drivers/gpu/drm/i915/intel_dp.c > @@ -1567,6 +1567,20 @@ intel_dp_link_down(struct intel_dp *intel_dp) > POSTING_READ(intel_dp->output_reg); > } > > +static enum drm_connector_status > +i915_dp_detect_common(struct intel_dp *intel_dp) Maybe you can fix the prefix of this function while you're at it since it's not i915 or even i9xx specific? -- Jesse Barnes, Intel Open Source Technology Center