From mboxrd@z Thu Jan 1 00:00:00 1970 From: Ben Widawsky Subject: Re: [PATCH 0/5] execbuffer cleanups + fixes Date: Wed, 12 Oct 2011 09:59:51 -0700 Message-ID: <20111012095951.68b078bf@bwidawsk.net> References: <1318394633-11143-1-git-send-email-ben@bwidawsk.net> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from cloud01.chad-versace.us (184-106-247-128.static.cloud-ips.com [184.106.247.128]) by gabe.freedesktop.org (Postfix) with ESMTP id 96A1E9E7A6 for ; Wed, 12 Oct 2011 09:59:49 -0700 (PDT) In-Reply-To: <1318394633-11143-1-git-send-email-ben@bwidawsk.net> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Ben Widawsky Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Tue, 11 Oct 2011 21:43:48 -0700 Ben Widawsky wrote: > Some refactors, a bug fixes (found through refactoring), as well as > setting a bit because the docs says so. That bit is hanging Daniel's > machine, so we may want to hold off on the last patch for now. > > This patch series is in preparation for some other work I'm doing in > this area of the code. I think this should be less risky, less > interesting, and require more nitpicking. That is why I am unleashing it > now. > > Ben Widawsky (5): > drm/i915: execbuffer simplification > drm/i915: extract constant offset setting > drm/i915: make eb structure do more > drm/i915: relative_constants_mode race fix > drm/i915: Force sync command ordering (Gen6+) > > drivers/gpu/drm/i915/i915_gem_execbuffer.c | 188 +++++++++++++++------------- > drivers/gpu/drm/i915/i915_reg.h | 1 + > drivers/gpu/drm/i915/intel_ringbuffer.c | 2 + > 3 files changed, 105 insertions(+), 86 deletions(-) > As a whole, the series is fine, but I accidentally put a hunk in patch 2 that belonged in patch 5. Since patch 2 comments specifically say it's just a refactor (when it's actually a functional change) I think I must nak the series. Please continue to comment and give feedback which I can incorporate on the respin. Ben