From mboxrd@z Thu Jan 1 00:00:00 1970 From: Ben Widawsky Subject: Re: [PATCH] drm/i915: consolidate interrupt naming scheme Date: Mon, 21 May 2012 14:01:52 -0700 Message-ID: <20120521140152.49a91dd4@bwidawsk.net> References: <1337356929-27188-1-git-send-email-ben@bwidawsk.net> <1337589967_155276@CP5-2952> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from cloud01.chad-versace.us (184-106-247-128.static.cloud-ips.com [184.106.247.128]) by gabe.freedesktop.org (Postfix) with ESMTP id 362BC9E75A for ; Mon, 21 May 2012 14:03:38 -0700 (PDT) In-Reply-To: <1337589967_155276@CP5-2952> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Chris Wilson Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Mon, 21 May 2012 09:46:00 +0100 Chris Wilson wrote: > On Fri, 18 May 2012 09:02:09 -0700, Ben Widawsky wrote: > > here are some opportunities to do things a bit better with the naming of > > things now that our hindsight is better. > > The major problem with this is that it breaks the expectations of the > INTEL_ namespace, masquerading per-gen values as fixed constants for all > chipsets. > -Chris > With only a couple of exceptions (BSD user interrupt) there is no need for per-gen values. I think we shouldn't have much trouble maintaining this as is. The existing naming scheme wrongly calls things GEN6 when they were introduced earlier (I'm also not sure GT_ is valid for every interrupt). So the goal was to have I915_* for old stuff, INTEL_* for everything, and DEVICENAME_ for special cases. -- Ben Widawsky, Intel Open Source Technology Center