From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH] drm/i915: cache the EDID for eDP panels Date: Fri, 15 Jun 2012 19:41:28 +0200 Message-ID: <20120615174128.GB4799@phenom.ffwll.local> References: <1339702113-2961-1-git-send-email-jbarnes@virtuousgeek.org> <87wr39ni4h.fsf@intel.com> <20120615103106.730ab802@jbarnes-desktop> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-we0-f177.google.com (mail-we0-f177.google.com [74.125.82.177]) by gabe.freedesktop.org (Postfix) with ESMTP id CCA1C9E768 for ; Fri, 15 Jun 2012 10:39:56 -0700 (PDT) Received: by werc12 with SMTP id c12so2526041wer.36 for ; Fri, 15 Jun 2012 10:39:56 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20120615103106.730ab802@jbarnes-desktop> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Jesse Barnes Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Fri, Jun 15, 2012 at 10:31:06AM -0700, Jesse Barnes wrote: > On Fri, 15 Jun 2012 10:34:22 +0300 > Jani Nikula wrote: > > Hi Jesse, I'm sure you meant to do *something* with that return value. I > > presume it should be equal to intel_dp->edid_mode_count, but is it > > possible it's not? Is it better to return ret or > > intel_dp->edid_mode_count from this function? > > > > Heh there's always something... but yeah it should be equal to the > mode_count; I should either drop the ret= or use it. Maybe as a > cleanup on top since I'm tired of respinning this one? :p I guess we can mend that bikeshed when we unify the panel handling some more between lvds and eDP. Patch merged for -fixes, thanks. -Daniel -- Daniel Vetter Mail: daniel@ffwll.ch Mobile: +41 (0)79 365 57 48