From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 2/6] drm/i915: Don't wait for page flips if there was GPU reset Date: Wed, 13 Feb 2013 12:49:14 +0100 Message-ID: <20130213114914.GG5813@phenom.ffwll.local> References: <1359476018-31274-1-git-send-email-ville.syrjala@linux.intel.com> <1359476018-31274-3-git-send-email-ville.syrjala@linux.intel.com> <20130213102328.GB20865@dyon.amr.corp.intel.com> <20130213105133.GN9135@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Return-path: Received: from mail-wi0-f169.google.com (mail-wi0-f169.google.com [209.85.212.169]) by gabe.freedesktop.org (Postfix) with ESMTP id 90BA6E6619 for ; Wed, 13 Feb 2013 03:46:59 -0800 (PST) Received: by mail-wi0-f169.google.com with SMTP id l13so5774264wie.0 for ; Wed, 13 Feb 2013 03:46:58 -0800 (PST) Content-Disposition: inline In-Reply-To: <20130213105133.GN9135@intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Ville =?iso-8859-1?Q?Syrj=E4l=E4?= Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Wed, Feb 13, 2013 at 12:51:33PM +0200, Ville Syrj=E4l=E4 wrote: > On Wed, Feb 13, 2013 at 10:23:28AM +0000, Damien Lespiau wrote: > > On Tue, Jan 29, 2013 at 06:13:34PM +0200, ville.syrjala@linux.intel.com= wrote: > > > From: Ville Syrj=E4l=E4 > > > = > > > If a GPU reset occurs while a page flip has been submitted to the rin= g, > > > the flip will never complete once the ring has been reset. > > > = > > > The GPU reset can be detected by sampling the reset_counter before the > > > flip is submitted, and then while waiting for the flip, the sampled > > > counter is compared with the current reset_counter value. > > > = > > > Signed-off-by: Ville Syrj=E4l=E4 > > = > > Reviewed-by: Damien Lespiau > > = > > You might want to rename reset_counter to flip_reset_counter to indicate > > this field is specific to the flipping code. Other parts of the code > > might need something similar as well? > = > IIRC I used flip_reset_counter initially but then I decided it's too > long and dropped the flip_ part. I can change it back if that's what > people prefer. Imo the generic reset_counter name is ok. At least as long as we don't need to keep track of more than one of these per crtc for different things (or if we ever start to add more fine-grained reset domains). -Daniel -- = Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch