From mboxrd@z Thu Jan 1 00:00:00 1970 From: Chris Wilson Subject: Re: [PATCH v2 10/16] drm/i915: add struct ctx_reset_state Date: Fri, 15 Mar 2013 09:52:43 +0000 Message-ID: <20130315095243.GD1204@cantiga.alporthouse.com> References: <1363276337-12509-1-git-send-email-mika.kuoppala@intel.com> <1363276337-12509-11-git-send-email-mika.kuoppala@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mga14.intel.com (mga14.intel.com [143.182.124.37]) by gabe.freedesktop.org (Postfix) with ESMTP id 3B208E638D for ; Fri, 15 Mar 2013 02:52:49 -0700 (PDT) Content-Disposition: inline In-Reply-To: <1363276337-12509-11-git-send-email-mika.kuoppala@intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Mika Kuoppala Cc: intel-gfx@lists.freedesktop.org, miku@iki.fi List-Id: intel-gfx@lists.freedesktop.org On Thu, Mar 14, 2013 at 05:52:11PM +0200, Mika Kuoppala wrote: > To count context losses, add struct ctx_reset_state for > both i915_hw_context and drm_i915_file_private. > drm_i915_file_private is used when there is no context. Being really picky, but can we device a better name than reset_state. I keep reading 'reset' as a verb and get very confused... Even just gpu_reset reads better. Suggestions? -Chris -- Chris Wilson, Intel Open Source Technology Centre