From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH v2 10/16] drm/i915: add struct ctx_reset_state Date: Sun, 17 Mar 2013 22:51:17 +0100 Message-ID: <20130317215117.GF9021@phenom.ffwll.local> References: <1363276337-12509-1-git-send-email-mika.kuoppala@intel.com> <1363276337-12509-11-git-send-email-mika.kuoppala@intel.com> <20130315095243.GD1204@cantiga.alporthouse.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-ee0-f44.google.com (mail-ee0-f44.google.com [74.125.83.44]) by gabe.freedesktop.org (Postfix) with ESMTP id 9303BE5F2B for ; Sun, 17 Mar 2013 14:48:32 -0700 (PDT) Received: by mail-ee0-f44.google.com with SMTP id l10so2390436eei.31 for ; Sun, 17 Mar 2013 14:48:31 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20130315095243.GD1204@cantiga.alporthouse.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Chris Wilson , Mika Kuoppala , intel-gfx@lists.freedesktop.org, miku@iki.fi List-Id: intel-gfx@lists.freedesktop.org On Fri, Mar 15, 2013 at 09:52:43AM +0000, Chris Wilson wrote: > On Thu, Mar 14, 2013 at 05:52:11PM +0200, Mika Kuoppala wrote: > > To count context losses, add struct ctx_reset_state for > > both i915_hw_context and drm_i915_file_private. > > drm_i915_file_private is used when there is no context. > > Being really picky, but can we device a better name than reset_state. I > keep reading 'reset' as a verb and get very confused... > > Even just gpu_reset reads better. Suggestions? hang_stats? failure_stats? In any case the struct definition itself needs a i915_ prefix. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch