From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jesse Barnes Subject: Re: [PATCH 5/8] drm/i915: Move hotplug interrupt enable for i915/i965/valleyview into a separate function. Date: Tue, 26 Mar 2013 13:04:23 -0700 Message-ID: <20130326130423.347e0ef5@jbarnes-desktop> References: <1357830166-18049-1-git-send-email-eich@suse.de> <1357830166-18049-6-git-send-email-eich@suse.de> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from oproxy14-pub.unifiedlayer.com (oproxy14-pub.unifiedlayer.com [67.222.51.224]) by gabe.freedesktop.org (Postfix) with SMTP id D7C76E64CE for ; Tue, 26 Mar 2013 13:04:08 -0700 (PDT) In-Reply-To: <1357830166-18049-6-git-send-email-eich@suse.de> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Egbert Eich Cc: Daniel Vetter , intel-gfx@lists.freedesktop.org, Chris Wilson , Rodrigo Vivi List-Id: intel-gfx@lists.freedesktop.org On Thu, 10 Jan 2013 10:02:43 -0500 Egbert Eich wrote: > Signed-off-by: Egbert Eich > --- > drivers/gpu/drm/i915/i915_irq.c | 178 ++++++++++++++++++++++---------------- > 1 files changed, 103 insertions(+), 75 deletions(-) > > diff --git a/drivers/gpu/drm/i915/i915_irq.c b/drivers/gpu/drm/i915/i915_irq.c > index 4e75df0..356472f 100644 > --- a/drivers/gpu/drm/i915/i915_irq.c > +++ b/drivers/gpu/drm/i915/i915_irq.c > @@ -567,6 +567,32 @@ static void gen6_queue_rps_work(struct drm_i915_private *dev_priv, > queue_work(dev_priv->wq, &dev_priv->rps.work); > } > > +static void valleyview_enable_hotplug_irq(struct drm_device *dev) Given how you use these later, _reset_hotplug_irq or _update_hotplug_irq might be a better name, but that's no biggie. Seems like a nice cleanup by itself even. Reviewed-by: Jesse Barnes -- Jesse Barnes, Intel Open Source Technology Center