From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH v2 3/3] drm/i915: drop code duplication in favor of asle interrupt handler Date: Thu, 25 Apr 2013 15:41:23 +0200 Message-ID: <20130425134122.GF6169@phenom.ffwll.local> References: <39ef9d9d21a2211333ce011881e240304c3baec1.1366830005.git.jani.nikula@intel.com> <20130425130947.GA10193@strange.amr.corp.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-ea0-f182.google.com (mail-ea0-f182.google.com [209.85.215.182]) by gabe.freedesktop.org (Postfix) with ESMTP id 93314E5C73 for ; Thu, 25 Apr 2013 06:38:20 -0700 (PDT) Received: by mail-ea0-f182.google.com with SMTP id r16so1268395ead.13 for ; Thu, 25 Apr 2013 06:38:19 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20130425130947.GA10193@strange.amr.corp.intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Damien Lespiau Cc: Jani Nikula , intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Thu, Apr 25, 2013 at 02:09:47PM +0100, Damien Lespiau wrote: > On Wed, Apr 24, 2013 at 10:18:44PM +0300, Jani Nikula wrote: > > With the previous work asle and gse interrupt handlers should now be > > functionally the same. Drop the duplicated code. > > > > v2: Drop intel_opregion_gse_intr() also in the !CONFIG_ACPI path. (Damien) > > > > Signed-off-by: Jani Nikula > > To be explicit about it: > > Reviewed-by: Damien Lespiau Merged all three patches, thanks. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch