From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 4/5] drm/i915: Apply OCD to data/link m/n register #defines Date: Fri, 3 May 2013 11:15:08 +0200 Message-ID: <20130503091508.GJ5763@phenom.ffwll.local> References: <1367424197-29664-1-git-send-email-daniel.vetter@ffwll.ch> <1367424197-29664-4-git-send-email-daniel.vetter@ffwll.ch> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-wg0-f51.google.com (mail-wg0-f51.google.com [74.125.82.51]) by gabe.freedesktop.org (Postfix) with ESMTP id A6B55E5C57 for ; Fri, 3 May 2013 02:12:04 -0700 (PDT) Received: by mail-wg0-f51.google.com with SMTP id b13so1402012wgh.30 for ; Fri, 03 May 2013 02:12:03 -0700 (PDT) Content-Disposition: inline In-Reply-To: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Paulo Zanoni Cc: Daniel Vetter , Intel Graphics Development List-Id: intel-gfx@lists.freedesktop.org On Thu, May 02, 2013 at 05:36:33PM -0300, Paulo Zanoni wrote: > Hi > > 2013/5/1 Daniel Vetter : > > - PCH_ prefix for pch registers on ibx/cpt/ppt. > > - Drop the DP_ from the link defines, redundant. > > - Drop the GMCH from the data defines and instead give the special g4x > > registers a consistent _G4X postfix. > > > > Signed-off-by: Daniel Vetter > > Yay, the new naming is way better. Thanks! > > So since this is about OCD, I'll give my optional OCD bikesheds: > - Now the register addresses are not aligned on i915_reg.h anymore. I > suggest we align them again. We should also consider replacing all > those white spaces with tabs. Done. > - We should have renamed the suspend/resume regfile registers too. > They're getting confusing now. Imo i915_ums.c is a dungeon and I don't want to change anything in there if at all possible. Hence why I've kept the old names. > - We go over 80 columns in some new cases now. Do we have a policy on > when it's accepted on our driver? I don't mind too much if something in the dungeons (i915_ums.c and i915_dma.c overflows). Same for reg defines, since usually you don't really read them that often. Real code in source files shouldn't overflow for easier reading (with some exceptions for strings). > - Reviewed-by: Paulo Zanoni but I'd love to > see my bikesheds on v2 :) On it's way ;-) -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch