From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [Intel-gfx] [PATCH 3/3] drm: Fix drm_rect documentation Date: Wed, 8 May 2013 15:55:19 +0200 Message-ID: <20130508135519.GR5763@phenom.ffwll.local> References: <1368020315-4820-1-git-send-email-ville.syrjala@linux.intel.com> <1368020315-4820-4-git-send-email-ville.syrjala@linux.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Return-path: Content-Disposition: inline In-Reply-To: <1368020315-4820-4-git-send-email-ville.syrjala@linux.intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org Errors-To: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org To: ville.syrjala@linux.intel.com Cc: intel-gfx@lists.freedesktop.org, Laurent Pinchart , dri-devel@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Wed, May 08, 2013 at 04:38:35PM +0300, ville.syrjala@linux.intel.com wro= te: > From: Ville Syrj=E4l=E4 > = > The 'struct' keyword was missing so struct drm_rect documentation never > ended up in the generated docs. > = > Also reorder drm_rect.h to become before drm_rect.c so that the struct > documentation appears first in the docs. And change it to use the 'I' > directive instead of 'F' while we're at it. > = > Signed-off-by: Ville Syrj=E4l=E4 > --- > Documentation/DocBook/drm.tmpl | 2 +- > include/drm/drm_rect.h | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > = > diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.t= mpl > index 7c7af25..89b6faa 100644 > --- a/Documentation/DocBook/drm.tmpl > +++ b/Documentation/DocBook/drm.tmpl > @@ -1653,8 +1653,8 @@ void intel_crt_init(struct drm_device *dev) > > KMS API Functions > !Edrivers/gpu/drm/drm_crtc.c > +!Iinclude/drm/drm_rect.h > !Edrivers/gpu/drm/drm_rect.c > -!Finclude/drm/drm_rect.h Shameless bikeshed while at it: Can you move the drm_rect stuff to it's own sections, like all the other kms helper stuff? Only the things in drm_crtc.c are really core kms apis. -Daniel > > > = > diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h > index 64fa265..9a98321 100644 > --- a/include/drm/drm_rect.h > +++ b/include/drm/drm_rect.h > @@ -25,7 +25,7 @@ > #define DRM_RECT_H > = > /** > - * drm_rect - two dimensional rectangle > + * struct drm_rect - two dimensional rectangle > * @x1: horizontal starting coordinate (inclusive) > * @x2: horizontal ending coordinate (exclusive) > * @y1: vertical starting coordinate (inclusive) > -- = > 1.8.1.5 > = > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx -- = Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch