From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH] drm/i915: Refactor the wait_rendering completion into a common routine Date: Sat, 29 Jun 2013 17:55:19 +0200 Message-ID: <20130629155519.GZ18285@phenom.ffwll.local> References: <1372491364-28288-1-git-send-email-chris@chris-wilson.co.uk> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-wg0-f49.google.com (mail-wg0-f49.google.com [74.125.82.49]) by gabe.freedesktop.org (Postfix) with ESMTP id E3AB9E5D32 for ; Sat, 29 Jun 2013 08:55:21 -0700 (PDT) Received: by mail-wg0-f49.google.com with SMTP id a12so2573902wgh.16 for ; Sat, 29 Jun 2013 08:55:20 -0700 (PDT) Content-Disposition: inline In-Reply-To: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Chris Wilson Cc: intel-gfx List-Id: intel-gfx@lists.freedesktop.org On Sat, Jun 29, 2013 at 04:35:57PM +0200, Daniel Vetter wrote: > On Sat, Jun 29, 2013 at 9:36 AM, Chris Wilson wrote: > > Harmonise the completion logic between the non-blocking and normal > > wait_rendering paths, and move that logic into a common function. > > > > In the process, we note that the last_write_seqno is by definition the > > earlier of the two read/write seqnos and so all successful waits will > > have passed the last_write_seqno. Therefore we can unconditionally clear > > the write seqno and its domains in the completion logic. > > > > Signed-off-by: Chris Wilson > > Looks really nice. Still I'd like to see some i-g-t nastiness > increases before we frob this code some more. So I'll punt on this for > now ... I'm happy about the new tests, so merged this patch to dinq. Thanks for botht the cleanup and the igt tests. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch