From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 4/4] drm/i915: add error_state sysfs entry Date: Mon, 1 Jul 2013 18:56:46 +0200 Message-ID: <20130701165646.GV18285@phenom.ffwll.local> References: <20130606134853.GB20552@cantiga.alporthouse.com> <1370529534-4573-1-git-send-email-mika.kuoppala@intel.com> <20130701161959.GB4340@cantiga.alporthouse.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-ea0-f171.google.com (mail-ea0-f171.google.com [209.85.215.171]) by gabe.freedesktop.org (Postfix) with ESMTP id 8BC29E5C25 for ; Mon, 1 Jul 2013 09:56:48 -0700 (PDT) Received: by mail-ea0-f171.google.com with SMTP id m14so2208955eaj.2 for ; Mon, 01 Jul 2013 09:56:47 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20130701161959.GB4340@cantiga.alporthouse.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Chris Wilson , Mika Kuoppala , intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Mon, Jul 01, 2013 at 05:19:59PM +0100, Chris Wilson wrote: > On Thu, Jun 06, 2013 at 05:38:54PM +0300, Mika Kuoppala wrote: > > As getting error state doesn't anymore require big kmallocs, > > make error state accessible also from sysfs. > > > > v2: - error state clearing (Chris Wilson) > > - user hint, proper access mode bits and name (Daniel Vetter) > > > > v3: release resources in proper order (Chris Wilson) > > > > Suggested-by: Daniel Vetter > > Signed-off-by: Mika Kuoppala > > I am happy overall here. We could take the plunge and use this as an > excuse to move all the error-state string handling into a new file, > which would be useful for when we pull the hangcheck mechanism out of > i915_irq.c. > > Perhaps the more pressing bikeshed is that after years of > i915_error_state, I'm tired of the name and think that the 'state' was > just redundant, so perhaps '/sys/class/drm/card0/error' is a nice > minimalist and modern looking name. Series merged with this bikeshed applied and your r-b from irc added. Thanks, Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch