From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 07/13] drm/i915: Add register whitelist for DRM master Date: Thu, 30 Jan 2014 10:02:02 +0100 Message-ID: <20140130090202.GH17001@phenom.ffwll.local> References: <1385484699-51596-1-git-send-email-bradley.d.volkin@intel.com> <1391032514-19136-1-git-send-email-bradley.d.volkin@intel.com> <1391032514-19136-8-git-send-email-bradley.d.volkin@intel.com> <20140129223725.GP28110@nuc-i3427.alporthouse.com> <20140129231821.GA20009@vpg-ubuntu-bdvolkin> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-ee0-f43.google.com (mail-ee0-f43.google.com [74.125.83.43]) by gabe.freedesktop.org (Postfix) with ESMTP id 86887FA557 for ; Thu, 30 Jan 2014 01:02:12 -0800 (PST) Received: by mail-ee0-f43.google.com with SMTP id c41so1433989eek.30 for ; Thu, 30 Jan 2014 01:02:11 -0800 (PST) Content-Disposition: inline In-Reply-To: <20140129231821.GA20009@vpg-ubuntu-bdvolkin> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces@lists.freedesktop.org Errors-To: intel-gfx-bounces@lists.freedesktop.org To: "Volkin, Bradley D" Cc: "intel-gfx@lists.freedesktop.org" List-Id: intel-gfx@lists.freedesktop.org On Wed, Jan 29, 2014 at 03:18:21PM -0800, Volkin, Bradley D wrote: > On Wed, Jan 29, 2014 at 02:37:25PM -0800, Chris Wilson wrote: > > On Wed, Jan 29, 2014 at 01:55:08PM -0800, bradley.d.volkin@intel.com wrote: > > > From: Brad Volkin > > > > > > These are used to implement scanline waits in the X server. > > > > > > Signed-off-by: Brad Volkin > > > --- > > > drivers/gpu/drm/i915/i915_cmd_parser.c | 30 ++++++++++++++++++++++++++++++ > > > 1 file changed, 30 insertions(+) > > > > > > diff --git a/drivers/gpu/drm/i915/i915_cmd_parser.c b/drivers/gpu/drm/i915/i915_cmd_parser.c > > > index 18d5b05..296e322 100644 > > > --- a/drivers/gpu/drm/i915/i915_cmd_parser.c > > > +++ b/drivers/gpu/drm/i915/i915_cmd_parser.c > > > @@ -234,6 +234,20 @@ static const u32 gen7_blt_regs[] = { > > > BCS_SWCTRL, > > > }; > > > > > > +/* Whitelists for the DRM master. Magic numbers are taken from sna, to match. */ > > > > It would be wiser to use the kernel defines, makes it look like we are > > actually in charge. ;-) > > Will fix, though based on the sna commit history, it looks like you're in charge > either way :) Yeah, for the register tables I think we really should use symbolic values consistently, adding new ones if i915_reg.h has them lacking. At least as long as the lists are this short. Aside: The bkm for getting big feature work which adds lots of register #defines like this is to split out patches with just the #defines. That way those can be reviewed independently from any discussions about the code itself and so merged early. Helps with rebasing pains ;-) Cheers, Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch