From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 6/7] drm/i915: Fix framecount offset Date: Thu, 3 Apr 2014 11:30:16 +0200 Message-ID: <20140403093016.GZ7225@phenom.ffwll.local> References: <1396279290-29435-1-git-send-email-ville.syrjala@linux.intel.com> <1396279290-29435-7-git-send-email-ville.syrjala@linux.intel.com> <20140402102908.480cd93f@jbarnes-desktop> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-wi0-f174.google.com (mail-wi0-f174.google.com [209.85.212.174]) by gabe.freedesktop.org (Postfix) with ESMTP id C4A906E8AD for ; Thu, 3 Apr 2014 02:30:20 -0700 (PDT) Received: by mail-wi0-f174.google.com with SMTP id d1so8748538wiv.7 for ; Thu, 03 Apr 2014 02:30:19 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20140402102908.480cd93f@jbarnes-desktop> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: intel-gfx-bounces@lists.freedesktop.org Sender: "Intel-gfx" To: Jesse Barnes Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Wed, Apr 02, 2014 at 10:29:08AM -0700, Jesse Barnes wrote: > On Mon, 31 Mar 2014 18:21:29 +0300 > ville.syrjala@linux.intel.com wrote: > > > From: Rafael Barbalho > > > > The framecount register was still using the old PIPE macro instead > > of the new PIPE2 macro > > > > Signed-off-by: Rafael Barbalho > > --- > > drivers/gpu/drm/i915/i915_reg.h | 6 +++--- > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > > diff --git a/drivers/gpu/drm/i915/i915_reg.h b/drivers/gpu/drm/i915/i915_reg.h > > index a47b4c3..b6441da 100644 > > --- a/drivers/gpu/drm/i915/i915_reg.h > > +++ b/drivers/gpu/drm/i915/i915_reg.h > > @@ -3623,9 +3623,9 @@ enum punit_power_well { > > #define PIPE_PIXEL_MASK 0x00ffffff > > #define PIPE_PIXEL_SHIFT 0 > > /* GM45+ just has to be different */ > > -#define _PIPEA_FRMCOUNT_GM45 (dev_priv->info.display_mmio_offset + 0x70040) > > -#define _PIPEA_FLIPCOUNT_GM45 (dev_priv->info.display_mmio_offset + 0x70044) > > -#define PIPE_FRMCOUNT_GM45(pipe) _PIPE(pipe, _PIPEA_FRMCOUNT_GM45, _PIPEB_FRMCOUNT_GM45) > > +#define _PIPEA_FRMCOUNT_GM45 0x70040 > > +#define _PIPEA_FLIPCOUNT_GM45 0x70044 > > +#define PIPE_FRMCOUNT_GM45(pipe) _PIPE2(pipe, _PIPEA_FRMCOUNT_GM45) > > > > /* Cursor A & B regs */ > > #define _CURACNTR (dev_priv->info.display_mmio_offset + 0x70080) > > Oh fun. > > Reviewed-by: Jesse Barnes I've merged all the patches Jesse reviewed from this series, expect the one Damien has a bikeshed pending. Thanks, Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch