From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 06/50] drm/i915: s/intel_ring_buffer/intel_engine Date: Thu, 15 May 2014 22:52:18 +0200 Message-ID: <20140515205218.GX8790@phenom.ffwll.local> References: <1399637360-4277-1-git-send-email-oscar.mateo@intel.com> <1399637360-4277-7-git-send-email-oscar.mateo@intel.com> <20140513132827.GF3908@phenom.ffwll.local> <20140514132620.GA6515@strange.amr.corp.intel.com> <92648605EABDA246B775AAB04C95A7A3012EEA38@IRSMSX103.ger.corp.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-ee0-f51.google.com (mail-ee0-f51.google.com [74.125.83.51]) by gabe.freedesktop.org (Postfix) with ESMTP id 2504B6E1F9 for ; Thu, 15 May 2014 13:52:23 -0700 (PDT) Received: by mail-ee0-f51.google.com with SMTP id e51so1001429eek.38 for ; Thu, 15 May 2014 13:52:22 -0700 (PDT) Content-Disposition: inline In-Reply-To: <92648605EABDA246B775AAB04C95A7A3012EEA38@IRSMSX103.ger.corp.intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: intel-gfx-bounces@lists.freedesktop.org Sender: "Intel-gfx" To: "Mateo Lozano, Oscar" Cc: "intel-gfx@lists.freedesktop.org" List-Id: intel-gfx@lists.freedesktop.org On Thu, May 15, 2014 at 02:17:23PM +0000, Mateo Lozano, Oscar wrote: > > -----Original Message----- > > From: Lespiau, Damien > > Sent: Wednesday, May 14, 2014 2:26 PM > > To: Daniel Vetter > > Cc: Mateo Lozano, Oscar; intel-gfx@lists.freedesktop.org > > Subject: Re: [Intel-gfx] [PATCH 06/50] drm/i915: > > s/intel_ring_buffer/intel_engine > > > > On Tue, May 13, 2014 at 03:28:27PM +0200, Daniel Vetter wrote: > > > On Fri, May 09, 2014 at 01:08:36PM +0100, oscar.mateo@intel.com wrote: > > > > From: Oscar Mateo > > > > > > > > In the upcoming patches, we plan to break the correlation between > > > > engines (a.k.a. rings) and ringbuffers, so it makes sense to > > > > refactor the code and make the change obvious. > > > > > > > > No functional changes. > > > > > > > > Signed-off-by: Oscar Mateo > > > > > > If we rename stuff I'd vote for something close to Bspec language, > > > like CS. So maybe intel_cs_engine? > > Bikeshedding much, are we? :) > If we want to get closer to bspecish, intel_engine_cs would be better. I'm ok with that too ;-) > > Also, can we have such patches (and the like of "drm/i915: > > for_each_ring") pushed early when everyone is happy with them, they cause > > constant rebasing pain. > > I second that motion! Fully agreed - as soon as we have a rough sketch of where we want to go to I'll pull in the rename. Aside I highly suggest to do the rename with coccinelle and regerate it on rebases - that's much less error-prone than doing it by hand. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch