From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Volkin, Bradley D" Subject: Re: [PATCH 23/53] drm/i915: Generalize intel_ring_get_tail Date: Fri, 20 Jun 2014 13:17:27 -0700 Message-ID: <20140620201727.GA32083@bdvolkin-ubuntu-desktop> References: <1402673891-14618-1-git-send-email-oscar.mateo@intel.com> <1402673891-14618-24-git-send-email-oscar.mateo@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mga11.intel.com (mga11.intel.com [192.55.52.93]) by gabe.freedesktop.org (Postfix) with ESMTP id 62DA76E270 for ; Fri, 20 Jun 2014 13:16:34 -0700 (PDT) Content-Disposition: inline In-Reply-To: <1402673891-14618-24-git-send-email-oscar.mateo@intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: intel-gfx-bounces@lists.freedesktop.org Sender: "Intel-gfx" To: "oscar.mateo@intel.com" Cc: "intel-gfx@lists.freedesktop.org" List-Id: intel-gfx@lists.freedesktop.org On Fri, Jun 13, 2014 at 08:37:41AM -0700, oscar.mateo@intel.com wrote: > From: Oscar Mateo > > Reusing stuff, a penny at a time. > > Signed-off-by: Oscar Mateo > --- > drivers/gpu/drm/i915/i915_gem.c | 4 ++-- > drivers/gpu/drm/i915/intel_ringbuffer.h | 4 ++-- > 2 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/drivers/gpu/drm/i915/i915_gem.c b/drivers/gpu/drm/i915/i915_gem.c > index c5c06c9..dcdffab 100644 > --- a/drivers/gpu/drm/i915/i915_gem.c > +++ b/drivers/gpu/drm/i915/i915_gem.c > @@ -2320,7 +2320,7 @@ int __i915_add_request(struct intel_engine_cs *ring, > u32 request_ring_position, request_start; > int ret; > > - request_start = intel_ring_get_tail(ring); > + request_start = intel_ring_get_tail(ring->buffer); > /* > * Emit any outstanding flushes - execbuf can fail to emit the flush > * after having emitted the batchbuffer command. Hence we need to fix > @@ -2341,7 +2341,7 @@ int __i915_add_request(struct intel_engine_cs *ring, > * GPU processing the request, we never over-estimate the > * position of the head. > */ > - request_ring_position = intel_ring_get_tail(ring); > + request_ring_position = intel_ring_get_tail(ring->buffer); > > ret = ring->add_request(ring); > if (ret) > diff --git a/drivers/gpu/drm/i915/intel_ringbuffer.h b/drivers/gpu/drm/i915/intel_ringbuffer.h > index dc944fe..1558afa 100644 > --- a/drivers/gpu/drm/i915/intel_ringbuffer.h > +++ b/drivers/gpu/drm/i915/intel_ringbuffer.h > @@ -334,9 +334,9 @@ void intel_destroy_ring_buffer(struct intel_ringbuffer *ringbuf); > int intel_allocate_ring_buffer(struct drm_device *dev, > struct intel_ringbuffer *ringbuf); > > -static inline u32 intel_ring_get_tail(struct intel_engine_cs *ring) > +static inline u32 intel_ring_get_tail(struct intel_ringbuffer *ringbuf) > { > - return ring->buffer->tail; > + return ringbuf->tail; > } Another naming bikeshed, for this and the previous patch: It might be unexpected to have all of the intel_ring_ functions except for two take a struct intel_engine_cs and then have this and intel_ring_space take a struct intel_ringbuffer. So maybe intel_ringbuffer_ or similar for those two. Brad > > static inline u32 intel_ring_get_seqno(struct intel_engine_cs *ring) > -- > 1.9.0 > > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx