From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH] drm/i915: Make hpd debug messages less cryptic Date: Mon, 11 Aug 2014 19:32:34 +0200 Message-ID: <20140811173234.GV10500@phenom.ffwll.local> References: <1407771457-14981-1-git-send-email-ville.syrjala@linux.intel.com> <20140811170524.GH21988@strange.ger.corp.intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Return-path: Received: from mail-we0-f178.google.com (mail-we0-f178.google.com [74.125.82.178]) by gabe.freedesktop.org (Postfix) with ESMTP id E68B66E290 for ; Mon, 11 Aug 2014 10:32:22 -0700 (PDT) Received: by mail-we0-f178.google.com with SMTP id w61so9003785wes.37 for ; Mon, 11 Aug 2014 10:32:22 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20140811170524.GH21988@strange.ger.corp.intel.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: intel-gfx-bounces@lists.freedesktop.org Sender: "Intel-gfx" To: Damien Lespiau Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org On Mon, Aug 11, 2014 at 06:05:24PM +0100, Damien Lespiau wrote: > On Mon, Aug 11, 2014 at 06:37:37PM +0300, ville.syrjala@linux.intel.com w= rote: > > From: Ville Syrj=E4l=E4 > > = > > Don't print raw numbers, use port_name() and tell the user whether it's > > long or short without having to figure out what the other magic number > > means. > > = > > Signed-off-by: Ville Syrj=E4l=E4 > = > Reviewed-by: Damien Lespiau Queued for -next, thanks for the patch. -Daniel > = > -- = > Damien > = > > --- > > drivers/gpu/drm/i915/i915_irq.c | 4 +++- > > drivers/gpu/drm/i915/intel_dp.c | 3 ++- > > 2 files changed, 5 insertions(+), 2 deletions(-) > > = > > diff --git a/drivers/gpu/drm/i915/i915_irq.c b/drivers/gpu/drm/i915/i91= 5_irq.c > > index 8e6729e..4a86fc5 100644 > > --- a/drivers/gpu/drm/i915/i915_irq.c > > +++ b/drivers/gpu/drm/i915/i915_irq.c > > @@ -1777,7 +1777,9 @@ static inline void intel_hpd_irq_handler(struct d= rm_device *dev, > > long_hpd =3D (dig_hotplug_reg >> dig_shift) & PORTB_HOTPLUG_LONG_D= ETECT; > > } > > = > > - DRM_DEBUG_DRIVER("digital hpd port %d %d\n", port, long_hpd); > > + DRM_DEBUG_DRIVER("digital hpd port %c - %s\n", > > + port_name(port), > > + long_hpd ? "long" : "short"); > > /* for long HPD pulses we want to have the digital queue happen, > > but we still want HPD storm detection to function. */ > > if (long_hpd) { > > diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/int= el_dp.c > > index 34e3c47..e5ada4f 100644 > > --- a/drivers/gpu/drm/i915/intel_dp.c > > +++ b/drivers/gpu/drm/i915/intel_dp.c > > @@ -4043,7 +4043,8 @@ intel_dp_hpd_pulse(struct intel_digital_port *int= el_dig_port, bool long_hpd) > > if (intel_dig_port->base.type !=3D INTEL_OUTPUT_EDP) > > intel_dig_port->base.type =3D INTEL_OUTPUT_DISPLAYPORT; > > = > > - DRM_DEBUG_KMS("got hpd irq on port %d - %s\n", intel_dig_port->port, > > + DRM_DEBUG_KMS("got hpd irq on port %c - %s\n", > > + port_name(intel_dig_port->port), > > long_hpd ? "long" : "short"); > > = > > if (long_hpd) { > > -- = > > 1.8.5.5 > > = > > _______________________________________________ > > Intel-gfx mailing list > > Intel-gfx@lists.freedesktop.org > > http://lists.freedesktop.org/mailman/listinfo/intel-gfx > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx -- = Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch