From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH 00/14] i915 kerneldocs part 1 Date: Wed, 1 Oct 2014 10:42:17 +0200 Message-ID: <20141001084217.GM12343@phenom.ffwll.local> References: <1412067410-9346-1-git-send-email-daniel.vetter@ffwll.ch> <1412082998.18498.17.camel@intelbox> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-wg0-f42.google.com (mail-wg0-f42.google.com [74.125.82.42]) by gabe.freedesktop.org (Postfix) with ESMTP id A402A6E539 for ; Wed, 1 Oct 2014 01:42:22 -0700 (PDT) Received: by mail-wg0-f42.google.com with SMTP id z12so470602wgg.13 for ; Wed, 01 Oct 2014 01:42:21 -0700 (PDT) Content-Disposition: inline In-Reply-To: <1412082998.18498.17.camel@intelbox> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: intel-gfx-bounces@lists.freedesktop.org Sender: "Intel-gfx" To: Imre Deak Cc: Daniel Vetter , Intel Graphics Development List-Id: intel-gfx@lists.freedesktop.org On Tue, Sep 30, 2014 at 04:16:38PM +0300, Imre Deak wrote: > On Tue, 2014-09-30 at 10:56 +0200, Daniel Vetter wrote: > > Hi all, > > > > So I've decided that it's really time to (slowly) crawl through i915 and > > document everything. It's going to take years, but here's a start at least. > > > > I realize that this has good chances to create a constant stream of little > > conflicts all over. Well, so be it, I really think we need this. > > > > Overall approach is fairly simple: > > 1. Clean up interfaces for a set of functions. > > 2. Extract them into a new file grouped nicely together. > > 3. Write kerneldoc including short overview section. > > 4. Repeat. > > > > So here's the first batch. Comments & flames highly welcome. Review assignments > > below (counts for all the patches above the block). > > > > Cheers, Daniel > > > > Daniel Vetter (14): > > drm/i915: Remove intel_modeset_suspend_hw > > drm/i915: Extract intel_runtime_pm.c > > drm/i915: Bikeshed rpm functions name a bit. > > drm/i915: Move intel_display_set_init_power to intel_runtime_pm.c > > drm/i915: Call runtime_pm_disable directly > > drm/i915: Kerneldoc for intel_runtime_pm.c > > > > Reviewer: Imre > > With the optional nitpicks I sent separately for the above 6 patches: > Reviewed-by: Imre Deak All nitpicks (plus a few more spelling fixes I've spotted) applied and patches merged, thanks a lot for your review. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch