From mboxrd@z Thu Jan 1 00:00:00 1970 From: Eric Anholt Subject: Re: RFC: i915 arch changes to better support new chipsets Date: Wed, 28 Mar 2012 13:29:26 -0700 Message-ID: <87obrgbhax.fsf@eliezer.anholt.net> References: <20120320111357.56093868@jbarnes-desktop> <20120320184304.GC27231@phenom.ffwll.local> <20120320131347.10427988@jbarnes-desktop> <20120321134121.6eef8b74@jbarnes-desktop> <871uocldra.fsf@eliezer.anholt.net> <20120328124616.21c5fa5a@jbarnes-desktop> Mime-Version: 1.0 Content-Type: multipart/mixed; boundary="===============0490088763==" Return-path: In-Reply-To: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: Eugeni Dodonov , Jesse Barnes Cc: intel-gfx@lists.freedesktop.org List-Id: intel-gfx@lists.freedesktop.org --===============0490088763== Content-Type: multipart/signed; boundary="=-=-="; micalg=pgp-sha1; protocol="application/pgp-signature" --=-=-= Content-Transfer-Encoding: quoted-printable On Wed, 28 Mar 2012 16:59:15 -0300, Eugeni Dodonov wro= te: > On Wed, Mar 28, 2012 at 16:46, Jesse Barnes wro= te: >=20 > > > I guess we could have the gen-number stuff be a union of > > > IS_IVB()/IS_HSW()/IS_VLV(), and switch chipset probing to using each = of > > > those instead of just gen >=3D 4. > > > > > > Does this sound sane? > > > > Yeah that might be better anyway, at least for the kernel where the > > IS_GEN stuff is getting more and more overloaded and I'd like to move > > away from it in some places. > > > > So if you're ok with it, that sounds like a good approach. > > >=20 > I think that we could move away from the IS_GEN checks in most places > actually, and not just in some of them, by using the feature checks inste= ad. >=20 > My latest branch reports gives `grep IS_GEN * | wc -l` =3D 112; and if we > look for recent chipsets, we have `grep IS_GEN[67] *` =3D 47. And most of > those checks have sub-checks as well for specific chip features or names. > So if we drop the IS_GEN macros, and just use the specific feature or GPU > name checks instead we should improve both the readability and decrease t= he > code complexity I think. A grep for IS_GEN will be significantly under-counting the number of places that gen numbers are used, given that Mesa uses intel->gen, and the 2d driver tends to use INTEL_INFO(intel)->gen. --=-=-= Content-Type: application/pgp-signature -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.12 (GNU/Linux) iEYEARECAAYFAk9zdKYACgkQHUdvYGzw6vca5wCePZNCJfdY8jcTxr/lpV+Ur6Dx mNkAoJfPLh4f3mkFNTaKhgdluw8e2/yY =GJ0G -----END PGP SIGNATURE----- --=-=-=-- --===============0490088763== Content-Type: text/plain; charset="us-ascii" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Content-Disposition: inline _______________________________________________ Intel-gfx mailing list Intel-gfx@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/intel-gfx --===============0490088763==--