Intel-Wired-Lan Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Ruinskiy, Dima" <dima.ruinskiy@intel.com>
To: <intel-wired-lan@osuosl.org>
Subject: Re: [Intel-wired-lan] [PATCH v3 2/2] e1000e: ignore factory-default checksum value on TGP platform
Date: Wed, 25 Jun 2025 20:10:08 +0300	[thread overview]
Message-ID: <783f54bd-9807-4874-94c8-1b99e914dd78@intel.com> (raw)
In-Reply-To: <20250625170050.GJ1562@horms.kernel.org>

On 25/06/2025 20:00, Simon Horman wrote:
> On Wed, Jun 25, 2025 at 05:06:44PM +0300, Vlad URSU wrote:
>> On 25.06.2025 16:05, Jacek Kowalski wrote:
>>>>>>> +#define NVM_CHECKSUM_FACTORY_DEFAULT 0xFFFF
>>>>>>
>>>>>> Perhaps it is too long, but I liked Vlad's suggestion of naming this
>>>>>> NVM_CHECKSUM_WORD_FACTORY_DEFAULT.
>>>
>>> So the proposals are:
>>>
>>> 1. NVM_CHECKSUM_WORD_FACTORY_DEFAULT
>>> 2. NVM_CHECKSUM_FACTORY_DEFAULT
>>> 3. NVM_CHECKSUM_INVALID
>>> 4. NVM_CHECKSUM_MISSING
>>> 5. NVM_CHECKSUM_EMPTY
>>> 6. NVM_NO_CHECKSUM
>>>
>>> Any other contenders?
>>>
>>
>> For reference, I called it "CHECKSUM_WORD" in my proposal because that's
>> what it's refered to as in the intel documentation (section 10.3.2.2 - http://www.intel.com/content/dam/www/public/us/en/documents/datasheets/ethernet-connection-i219-datasheet.pdf)
>>
> 
> FWIIW, I'd vote for 1.

I suggest NVM_CHECKSUM_UNINITIALIZED
(as this is what a value of 0xFFFF really means).


  reply	other threads:[~2025-06-25 17:10 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-06-24 19:07 [Intel-wired-lan] [PATCH v3 1/2] e1000e: disregard NVM checksum on tgp when valid checksum mask is not set Jacek Kowalski
2025-06-24 19:14 ` [Intel-wired-lan] [PATCH v3 2/2] e1000e: ignore factory-default checksum value on TGP platform Jacek Kowalski
2025-06-24 19:42   ` Simon Horman
2025-06-24 21:05     ` Jacek Kowalski
2025-06-25  9:44       ` Simon Horman
2025-06-25 13:05         ` Jacek Kowalski
2025-06-25 14:06           ` Vlad URSU
2025-06-25 17:00             ` Simon Horman
2025-06-25 17:10               ` Ruinskiy, Dima [this message]
2025-06-29  9:36           ` David Laight

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=783f54bd-9807-4874-94c8-1b99e914dd78@intel.com \
    --to=dima.ruinskiy@intel.com \
    --cc=intel-wired-lan@osuosl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox