Intel-Wired-Lan Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Hannes Frederic Sowa <hannes@redhat.com>
To: intel-wired-lan@osuosl.org
Subject: [Intel-wired-lan] [net-next PATCH v3 03/17] net: Merge VXLAN and GENEVE push notifiers into a single notifier
Date: Fri, 17 Jun 2016 00:47:30 +0200	[thread overview]
Message-ID: <ca1aecfd-ca23-e8ce-aa21-8a6a99a59c03@redhat.com> (raw)
In-Reply-To: <20160616192100.20872.88358.stgit@localhost.localdomain>

On 16.06.2016 21:21, Alexander Duyck wrote:
> This patch merges the notifiers for VXLAN and GENEVE into a single UDP
> tunnel notifier.  The idea is that we will want to only have to make one
> notifier call to receive the list of ports for VXLAN and GENEVE tunnels
> that need to be offloaded.
> 
> In addition we add a new set of ndo functions named ndo_udp_tunnel_add and
> ndo_udp_tunnel_del that are meant to allow us to track the tunnel meta-data
> such as port and address family as tunnels are added and removed.  The
> tunnel meta-data is now transported in a structure named udp_tunnel_info
> which for now carries the type, address family, and port number.  In the
> future this could be updated so that we can include a tuple of values
> including things such as the destination IP address and other fields.
> 
> I also ended up going with a naming scheme that consisted of using the
> prefix udp_tunnel on function names.  I applied this to the notifier and
> ndo ops as well so that it hopefully points to the fact that these are
> primarily used in the udp_tunnel functions.
> 
> Signed-off-by: Alexander Duyck <aduyck@mirantis.com>

Acked-by: Hannes Frederic Sowa <hannes@stressinduktion.org>



  reply	other threads:[~2016-06-16 22:47 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-06-16 19:20 [Intel-wired-lan] [net-next PATCH v3 00/17] Future-proof tunnel offload handlers Alexander Duyck
2016-06-16 19:20 ` [Intel-wired-lan] [net-next PATCH v3 01/17] vxlan/geneve: Include udp_tunnel.h in vxlan/geneve.h and fixup includes Alexander Duyck
2016-06-16 23:06   ` Hannes Frederic Sowa
2016-06-16 19:20 ` [Intel-wired-lan] [net-next PATCH v3 02/17] net: Combine GENEVE and VXLAN port notifiers into single functions Alexander Duyck
2016-06-16 22:45   ` Hannes Frederic Sowa
2016-06-16 19:21 ` [Intel-wired-lan] [net-next PATCH v3 03/17] net: Merge VXLAN and GENEVE push notifiers into a single notifier Alexander Duyck
2016-06-16 22:47   ` Hannes Frederic Sowa [this message]
2016-06-16 19:21 ` [Intel-wired-lan] [net-next PATCH v3 04/17] bnx2x: Move all UDP port notifiers to single function Alexander Duyck
2016-06-16 19:21 ` [Intel-wired-lan] [net-next PATCH v3 05/17] bnxt: Update drivers to support unified UDP encapsulation offload functions Alexander Duyck
2016-06-16 19:21 ` [Intel-wired-lan] [net-next PATCH v3 06/17] bnxt: Move GENEVE support from hard-coded port to using port notifier Alexander Duyck
2016-06-16 23:12   ` Michael Chan
2016-06-16 19:21 ` [Intel-wired-lan] [net-next PATCH v3 07/17] benet: Replace ndo_add/del_vxlan_port with ndo_add/del_udp_enc_port Alexander Duyck
2016-06-16 19:21 ` [Intel-wired-lan] [net-next PATCH v3 08/17] fm10k: " Alexander Duyck
2016-06-16 19:22 ` [Intel-wired-lan] [net-next PATCH v3 09/17] i40e: Move all UDP port notifiers to single function Alexander Duyck
2016-06-16 19:22 ` [Intel-wired-lan] [net-next PATCH v3 10/17] ixgbe: Replace ndo_add/del_vxlan_port with ndo_add/del_udp_enc_port Alexander Duyck
2016-06-16 19:22 ` [Intel-wired-lan] [net-next PATCH v3 11/17] mlx4_en: " Alexander Duyck
2016-06-16 19:22 ` [Intel-wired-lan] [net-next PATCH v3 12/17] mlx5_en: " Alexander Duyck
2016-06-16 19:22 ` [Intel-wired-lan] [net-next PATCH v3 13/17] nfp: " Alexander Duyck
2016-06-16 19:22 ` [Intel-wired-lan] [net-next PATCH v3 14/17] qede: Move all UDP port notifiers to single function Alexander Duyck
2016-06-16 19:23 ` [Intel-wired-lan] [net-next PATCH v3 15/17] qlcnic: Replace ndo_add/del_vxlan_port with ndo_add/del_udp_enc_port Alexander Duyck
2016-06-16 19:23 ` [Intel-wired-lan] [net-next PATCH v3 16/17] net: Remove deprecated tunnel specific UDP offload functions Alexander Duyck
2016-06-16 22:59   ` Hannes Frederic Sowa
2016-06-16 19:23 ` [Intel-wired-lan] [net-next PATCH v3 17/17] vxlan: Add new UDP encapsulation offload type for VXLAN-GPE Alexander Duyck
2016-06-16 23:01   ` Hannes Frederic Sowa
2016-06-18  3:26 ` [Intel-wired-lan] [net-next PATCH v3 00/17] Future-proof tunnel offload handlers David Miller
2016-06-20 17:05   ` Tom Herbert
2016-06-20 18:11     ` Hannes Frederic Sowa
2016-06-20 19:27       ` Tom Herbert
2016-06-20 21:36         ` Hannes Frederic Sowa
2016-06-20 21:45           ` Tom Herbert
2016-06-21  8:34       ` David Miller
2016-06-21  8:22     ` David Miller
2016-06-21 10:41       ` Edward Cree
2016-06-21 15:23       ` Hannes Frederic Sowa
2016-06-21 17:05       ` Alexander Duyck
2016-06-21 17:27         ` Edward Cree
2016-06-21 17:40           ` Hannes Frederic Sowa
2016-06-21 18:17             ` Alexander Duyck
2016-06-21 18:42               ` Tom Herbert
2016-06-21 21:34                 ` Hannes Frederic Sowa
2016-06-21 18:23             ` Edward Cree

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ca1aecfd-ca23-e8ce-aa21-8a6a99a59c03@redhat.com \
    --to=hannes@redhat.com \
    --cc=intel-wired-lan@osuosl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox